Conflicting Metadata Hash when minting with `--alonzo-era` flag

Hi! I’ve been building a multi-signature application. I would sign the transaction with a dummy key and send it over to the client where cardano-serialization-lib would change and remove the signed key with the signature of a dapp-compatible wallet.

Everything would go well until I would submit the transaction onto the blockchain. I would get a ConflictingMetadataHash error whenever I would resubmit. I tried to hardcode the hash to make it uniform throughout the client and the backend, but I would still run into the error.

But my tx would submit when I changed the --alonzo-era flag to the --mary-era flag. Why is this?

It seems I have the same problem, any solution?

i worked it out by specifying --mary-era

I have the same problem and I narrow it down to auxiliary data. I created an issue to cardano-serialization-lib Get auxilary_data from old tx and set it to new one via the constructor results wrong auxilary_data · Issue #396 · Emurgo/cardano-serialization-lib · GitHub