721 metadata troubleshooting

Hello everyone,
I came across an unusual situation and I could not find any information about it. I made a transaction with wallet A where I minted an NFT directly into a wallet B, sent some ADA to a wallet C and kept the reminder into wallet A.

This is the transaction on Cardanoscan: Transaction d66740f56f0520c2452a5fdec39719c6182e443297d32872642ad5ec3aaeebeb - Cardanoscan

The issue here is that the metadata did not pass properly and I could not see the image with pool.pm. To fix it, I decided to create another NFT with the same name and metadata and delete it afterwards in order to update the original NFT and it worked. Transaction: Transaction e2ac6be6466dbe50a36a55b90c6466af58359b56917f9abe80ab524abe1e559a - Cardanoscan

Now I come across the same situation with another NFT and I cannot see its image under pool.pm: pool.pm with the transaction: Transaction 266b21042e644a7f1f9945600e17f5fc3e8497295cbfb00dc1749ee20d122a23 - Cardanoscan

As you can see, Cardanoscan correctly identifies the tags “721” and “777” but not pool.pm. Do you guys have any idea about why is that?

Thank you very much in advance!

1 Like


I see the asset name is different for the asset name inside metadata file, both should match

Asset Name MilcaGirl
Asset name inside metadat Milca_Girl


Yep, that’s it.

Was also the problem with the first one. The original mint that didn’t work had “Standard” as asset name in the metadata, only the second one that worked had “Tattooed”.

Which address the asset is minted or transferred to, doesn’t make a difference.


Thank you very much for your solution and your time!

Thank you so much for taking the effort and pointing to the solution!