Core - gLiveview Blank but SLiveView fine

gLiveView working fine on relays.
On my newly established core (1 day old) the output is blank other than Tip: (diff) which counts up then resets.
All other fields are empty.

sLiveView shows data in all fields.

Any thoughts?
Thanks in advance.


Any update on this?

More Info. Screen Shots of the 2 different view.

I think something wrong with the environment variable which points to the current cardano-cli.
What is the output of the command which cardano-cli?

scripts]$ which cardano-cli

scripts]$ cardano-cli --version
cardano-cli 1.26.2 - linux-x86_64 - ghc-8.10
git rev 3531289c9f79eab7ac5d3272ce6e6821504fec4c

but even sLiveView not showing the first 3 lines correctly…
that is my output:

|   Simple Node Stats by Crypto2099    |
| Version             |         1.26.2 |
| Revision            |       3531289c |
| Peers (Out / In)    |           / 17 |
| Epoch / Block       |  267 / 5754841 |
| Slot                |       30193162 |
| Uptime (D:H:M:S)    |    23:00:50:28 |
| Transactions        |                |
| Chain Density       |         5.060% |
| KES PERIOD          |            232 |
| KES REMAINING       |              4 |
| SLOTS LED           |             12 |
| BLOCKS FORGED       |             12 |

do you have blocklog.db database file? after sourcing env file what is the content of $BLOCKLOG_DIR env variable?

[cardano@ip-172-31-68-247 scripts]$ grep BLOCKLOG_DIR env
#BLOCKLOG_DIR="${CNODE_HOME}/guild-db/blocklog" # Override default directory used to store block data for core node
[[ -z ${BLOCKLOG_DIR} ]] && BLOCKLOG_DIR="${CNODE_HOME}/guild-db/blocklog"

There is no backlog.db but I have also not yet produced a block.

The same is true for my node which works fine.


ok - so as you can see the version is filled in simpleLiveView -
that is the line which gets the version info:
version=$("$(command -v cardano-node)" version)
so execute this in the terminal where you call the liveview:
command -v cardano-node

[cardano@ip-172-31-68-247 scripts]$ command -v cardano-node

[cardano@ip-172-31-68-247 scripts]$ cardano-node version
cardano-node 1.26.2 - linux-x86_64 - ghc-8.10
git rev 3531289c9f79eab7ac5d3272ce6e6821504fec4c

1 Like

that is ok - so since this is working - how can be that by calling sLiveView the version info not displayed?

I added print statements to the code.
when I removed the ‘-e’ switch from the echo statement it worked

echo “| Version / Revision | ${INFO}${node_ver}${NC} |”

this did not (or at least not visibly)
echo -e “| Version / Revision | ${INFO}${node_ver}${NC} |”

I then changed my terminal color settings and it looks correct.
So something in the font color choices was causing the data to be displayed in a hidden color or something.

Thanks for helping me figure this out.
The same issue was going on with gLiveView as well as that is also looking correct now,

1 Like

Hmm, and what you changed in case of gliveview? also you modified the script to use echo with -e switch?

The script uses echo -e normally.
when I modified the script to remove the -e and then saw it work I suspected it was a font color issue so I changed the color palette of my terminal to the same as my Node (as I knew they worked). As soon as I did that all of the information became visible.

1 Like