SOLVED: LiveView "doesn't load"

Hey Guys,

This questions is coming from the telegram communities. We have a number of stake pool operators who see that the “LiveView” stops working after they have done a topology update to increase their peers. Even after the “revert” the issue remains the same. The BP does seem to be working in the background though. This seems to be the case with mostly lower spec servers although I’ve encountered it once on a very high-spec server operating the BP alone with no relays on the same server.

EDIT: Solution is in relation to the Mnemonic “Trick” , as a result of following the guide it also updates the “PATH” with a ““cardano-wallet-2020.7.28” directory. Removing that path in your Path in the .bashrc file will resolve the issue

same issue here! didn’t find a solution so far…

That’s odd. I am running LiveView just fine. Maybe you should consider using tmux or screen for running it in background. It has nothing to do with topology unless topology format is broken (validate your json). In that case you should get an error. If you start it directly, without that shell script, do you get LiveView?

The BP actually does work as netstat shows the connections it just doesn’t load in the LiveView, could there be a timeout that stops it from loading in?

I’ve seen about 10+ pool operators seeing the error,after a restart

I lost my live view after I was trying to configure my topology and ran the

This seems to be what is happening to most people I am talking to and myself… everything is up and running as showing with Grafana and I even have some decelerators but the liveview did stop for me once I configured the topology… the problem is that Grafana doesn’t show some key information that is needed to make sure everything is running properly, only that it is running…

I understand that it works and that is just not showing the LiveView. What I was trying to say is that you should exclude everything that can get in its (node’s) way and then see if it still does not work. Just run the node without any script. If it works, then start adding stuff and see where it breaks.

Make sure you have the following property set to true in your config file:
“TraceBlockFetchDecisions”: true,

Yeah, same error for me. So I’m basically shooting in the dark here trying to figure out if I’m connected or not…

This does not work for me… Seems there is no going back. How do you reset this? Recompile or delete the database?

You won’t solve anything by recompiling. The database could play a role in the problem though. Try removing it. Like I said, try running the node directly without any scripts and see what you get on the terminal. What it says? Are there any errors? What do you see in log files?

Alright, I will try deleting the database for one of the relays to begin with.

Where are the logs located? I can’t seem to find them.

Deleting the db-folder does not seem to help either… I’m kind of at a loss as to what would be causing this…

You need to have log path added in mainnet-config.json in two places:

“defaultScribes”: [


"setupScribes": [
      "scFormat": "ScText",
      "scKind": "StdoutSK",
      "scName": "stdout",
      "scRotation": null
      "scKind": "FileSK",
      "scName": "/srv/cardano/cardano-node/log/node.log",
      "scFormat": "ScJson"

Adjust the path to logfile to your own wish.

You are saying it’s not working but you need to provide some kind of output otherwise we won’t be able to help. What do you get when you start the node? A screenshot could be helpful or copy/paste the output.


Uploaded the log file here:

I’ve let it run a couple min after it started processing blocks. LiveView never appeared by the way. Stuck as per other posts

Everything seems ok in the log. Are you sure you have the following set in config file?
“TraceBlockFetchDecisions”: true,

This issue is quite strange.

I’ve already tried by just removing the db and then by creating a new unrelated relayNode and executing the command manually without tmux. But it didn’t help…

Config seems to be ok (it used to work with the same config) and logs are not showing any errors.

The nodes seem to do their job - i have the feeling that it’s just this UI component which is not loading anymore for some reason…

Yes it is set correctly, same config was always working before as well

Would be interesting to know if its somehow depending on the OS. What OS are you guys using?
I’m on Ubuntu 20.04 LTS…

I don’t think it’s OS. It worked before for him. I have Ubuntu 20.04.1 LTS as well. It’s something in the config. @theh1982 if you are doing some copying of config files or some other magic with the files make sure that the file you are using is really the one you think you are using. Also if you changed something in .bashrc you need to reload it or logout and then login. You probably know that but just in case you forgot. Many times is just some subtle change.

Hi, also suffering from this issue. Will try to investigate the issue and report back if I find a fix.