Created Node to do lobster challenge (which worked!) but now nodes starts then gets killed

Hi, just for fun I decided to interact with Lars smart contract to choose a Lobster name. I’m not a SPO and am just tech curious.
I spun up an Ubuntu VM (4CPU/8GBram, heaps of fast disk) and followed the guides to create a node, and used cardano-cli to create wallet key pair+wallet address so I could check out interacting with the lobster name scripts. It all worked really well, and was fascinating to get a tiny window into what it is all about :slight_smile:

But now the node (v1.29) runs for a little while and says killed with messages about ErrorPolicyConsumer /Just ConnectionExceptionTrace /SubscriberError and Parallel connection cancelled. It is not taxing the resources it has so I don’t think that is the issue.

Does anyone have any suggestions as to what it could be, or what I should do to fix this?

Thanks for any help, Fred

There is nothing to fix. Personally I do think those error/warning messages should be cleaned up and made more understandable.

Check the system logs for messages from the OOM killer killing the node for using too much memory.

8G is about what the node needs at the moment (UTxO set is growing fast) so you either need a machine with more RAM or you might get away with adding swap (I assume you currently have none).

Sorry screen shot wasn’t clear - it was killed off on next line.

You will be correct re the RAM/swap = I’ve watched it as it started up again, and it is blowing out the RAM/Swap as follows as soon as it starts writing out blocks.


I can allocate whatever it needs as it’s self hosted, so will bump them up a heap and fire it up again. Thanks so much for the guidance.

Also - would it help Cardano if I leave it running? Or does it mucks with expected distribution and/or doesn’t actually do anything useful then → I’ll shut it off

Not needed. Cardano has over 500 stake pool that regularly produce blocks and most of those stake pools have at least 2 nodes on the network. That makes Cardano sufficiently decentralised (in terms of number of active nodes).

OK will shut it down, was a fun experiment but!

Also you were correct re resources - it is back at the tip and running 8.4GB ram.



I spun up an Ubuntu VM 4CPU/8GBram, heaps of fast disk and followed challenge (which worked but now nodes starts then gets killed .
there is nothing to fix.


If you have not added at least a couple of Gig of swap space the node running in 8 Gig of RAM will OOM.