Creating a cardano node ami on aws with ubuntu 20.04

Hi all,

I am trying to create my node ami using packer and ansible. Everything goes well until this command:

cabal build cardano-cli cardano-node

I get the following error

“Installing library in /home/cardano/.cabal/store/ghc-8.10.4/incoming/new-41402/home/cardano/.cabal/store/ghc-8.10.4/shelley-spec-ledger-”, “/home/cardano/.cabal/store/ghc-8.10.4/incoming/new-41402/home/cardano/.cabal/store/ghc-8.10.4/shelley-spec-ledger- copyFile: resource exhausted (No space left on device)”]}

I figured might be due to my root device size, but it seems fine:

“launch_block_device_mappings”: [
“device_name”: “/dev/xvda”,
“volume_size”: 40,
“volume_type”: “gp2”,
“delete_on_termination”: true

I am following the install guide from coincashew.

I tried to increase the size to 80, but still stuck :frowning:

Check this topic

1 Like

I am using AWS. What type of server are you running? I was running 60 gig ssds and i just expanded them to 120. Though right now I am only using about 27 gigs on my Block producer and Relay.

I am currently using Ubuntu 20 on t3.xlarge (paying using partial up front, about .08 cents per hour for both my servers or $119.04 or $1,428.48 per year, its closer to $1700 though. As soon as ARM processors are more supported I plan to move to those and also planning to run a server eventually at home.

If you follow the Coincashew guide you should have no issues. I dont know what packer or ansible is so I cant help you with those. I just did it straight from the coincashew guide and followed it step by step and it works well.

Let me know if you have any other questions I might be able to help with.

Stop your instance you’re trying to increase the size on
Left hand nav: volumes link - select the volume id checkbox - actions button - modify volume - size inputfield and enter the size you want to increase it to. ( I recommend 100 gb or more )

Left hand nav: instances link - click on your instance - storage tab and you’ll see the volume size increased. - Action button - Start instance.

Also, i noticed your device map is “/dev/xvda”. → it might be “/dev/sda”, or “/dev/sda1”,

thanks! It might be ansible not cleaning up all its tempfiles from installing ghc and cabal. Going to try a clean up before installing the node.

1 Like

Thanks. I am following the same guide. Just want to automate everything. Do you think t3.large will work? It seems some people start with t3.medium. I also wanted to use ARM… There are actually ghc and cabal arm binaries.

1 Like

I started with a medium and started to run out of ram. Now with the 1.27.0 update it’s using even more ram which could be corrected with the next update. You could use a t3.large and a swap file. I didn’t really want to mess with all that do I just upgraded it for now to t3.xlarge

Also make sure you have EIP for your servers in case they crash from insufficient memory . Or your iPS will reset .

1 Like

thanks for the advice.