DAEDALUS WALLET - Catalyst -PGP signature verification

Hi guys,

Need your help as I am novice on all the Cardano technicals.This is the first ever time I am trying to install any wallet on my personal computer.

Intrigued by the functionality of voting I want to download DAEDALUS WALLET.

I like following the rules so I am trying to verify the signature before the installation of Catalyst.

I am using macOS big sur 11.1 version. i follow the process and :slight_smile:

1.SHA256 checksum is verified correctly with the terminal (checked all the numbers)
2. I sign in correctly and I verify with the details D325 87D4 090F E461 CAEE 0FF4 966E 5CB9 CBFA A9BA as per instructions.

However, at the very end this is the last verification I get.

Is this how it should be?

Thank you.

Looking forward to vote !!!

Hello,

Compare with this one from IOHK

Cheers,

Hi,

Thank you for the reply but I am not sure when you give me the link with instructions how this will help me.

As mentioned I followed everything step by step and on my last verification I receive this message.

So as mentioned above is if this is the message I should be receiving cause on instructions says otherwise or actually what I get is similar with the instructions but the numbers before the end are not being mentioned.

Please advise cause I have tried several times and I always get the same similar but not exactly the same.

Can I consider that I have verified the installer to continue with installation ?

Thank you.

Sorry,

  • The Verification Results dialog will then appear with the verdict in the Result column:
    1. “Signed by: IOHK Signing Authority signing.authority@iohk.io 1471941A – full trust” – if successful
    2. …anything else means there was no valid signature for the installer.

source

Cheers,

I know Alex, what should I do to verify it? I have spent 2 hours trying to verify it. Checking the source and re doing it.

Doesn’t make any sense to me… what should be my next step?

Is it something I am doing wrong or it’s because of my computer, I noticed that I am not having a supported macOS version?

I really don’t get it what is your issue; you need to donwload daedalus , pgp signature and checksum file

Then you should follow the steps in order to install the daedalus

I didn’t installed on linux, I have it on my phone… but it seems you have to follow some steps in order to install it

Cheers,

I have watched this video and I don’t even know how many others.

Still verification message at the end as in the beginning does not match !!!

It simply doesn’t work to verify it, which then obviously I don’t continue with the installation.

It’s so sad that I really like cardano and it’s so difficult even to get this thing up and running…

On mobile you can have it with 3 clicks ( as an alternative till you will solve the issue.)

Here is another topic , check the rdlrt comment

First and foremost, Thank you for the support.

Sadly, spending hours on this I have already read that topic you put forward.

The thing is that I don’t even know what kleopatra is and I don’t care!

Following exactly the instructions being provided multiple times checking addresses and directories this guys does not work.

I could progress with installation but I won’t. What’s the purpose of trying to verify the signature and when failing you go ahead anyway…

Following exactly the instructions provided, the exact message is not coming UP.

I am not sure what you mean with mobile…to go and download the mobile app you need to verify through the installed catalyst.

We have not even installed the dam thing , we are waiting outside on still verifying the signature.

Which makes me wonder how cardano will progress if myself who not consider I have a good level of working on computers cannot pass this simple step.

Is cardano the blockchain of the geeks… no offence…maybe just reality ?

Hi,

Maybe someone had this issue and it will help you to solve;

Cheers,

I think I went through the same process with the same problem. The confusion is because this instruction below from the catalyst website:

" The Verification Results dialog will then appear with the verdict in the Result column:

  1. Signed by: IOHK Signing Authority 1471941A – full trust” – if successful
  2. …anything else means there was no valid signature for the installer.

This does not match the actual text results given when checking the PGP signature. Instead, I get this: Screen Shot 2021-01-17 at 7.01.15 PM

I think it’s basically the same thing, and probably a valid signature verification, but given the application here, shouldn’t these results match perfectly, and not be ‘close enough’ ?

1 Like

First off, you’re doing an optional verification using a method that’s not specific to Cardano, its pretty common way to verify application signatures (you could do the same with any binary - for example , check here for OpenOffice ). The instructions are provided as sample to help you with verification and walk through the process.

Secondly, verifying SHA256 and PGP signature are two seperate process as shown on download page. Running SHA256 does not give you the prompt you shared in original post, and as you mention it was verified successfully using SHA256 method.

For PGP verification (second type of verification), the prompt you see is mentioned message simply is showing a different text, perhaps due to versions of GPG . At the most it is a documentation update that we need, I will pass that on to IOG who host the website.

It is for Windows, not relevant to you and you do not need to care either.

2 Likes

Thank you so much for the replies guys! I guess I cannot trust to download the wallet if this documentation on macOS is not updated.

Will wait for the update on their documentation on macOS otherwise based on their documentation is not a verifiable signature to trust and download the wallet!!!

This confusion hope soon is resolved as I really like the project and I want to support it.

Let’s hope and wish the team will make it as simple as possible for all users who want to join. Lots of things to happen before cardano can approach the average user.

You are spot on and described it much better than me !

Hey, how this works guys?

Are they changing the documentation for me to download the wallet or this is not happening , sorry do not know how it works ?

I really want to download the wallet but after it’s verified by documentation on website that is secure when I receive this message.

I’ve been using the wallet with no problems, but I’d suggest sending a support ticket to IOHK if you need confirmation that it’s all correct. I haven’t contacted support or found a clear answer on this either, so I just gave up and decided to use it. (hope it works lol)

I am also a new user having a separate but I think related problem. I was able to hash the installer binary (for Windows) using the utility in cmd.exe, and I got the right output. Are you saying that in that case signature verification with GPG4Win is redundant? I hope so because I cannot find the asc.exe file so I haven’t been able to perform that verification in Kleopatra.
(In these instructions: Daedalus - Downloads, i’m stuck at step 7)
~dw

I’m in the same boat and I think this is a simple UX problem. I assume that the “Verify Signature Instructions” have not been updated. The problem is that this is preventing me from trusting the Daedalus wallet.

24 days after, I am on the sad position still not having downloaded the wallet on my computer due to lack of trust. It’s probably just instructions to be updated but it doesn’t inspire any confidence to put hard earned money with this pending !

Pity, I like the project and wanted to support it. Maybe later when this is addressed.

1 Like

Hi @rspiros1986 ,

Firstly, on behalf of our team, I apologize for this late response.

We have conducted an investigation and found out that the reason why you received a different dialog was because you had a different (newer) version of GPG Services (comes when installing GPG Tools as per instruction), whereas the one that was used by the instruction was an older version of GPG Services.

Currently the latest GPG Services is version:2.1, If you install the latest version of GPG Tools (which you already have), you should be able to observe exactly the same dialog as the following:
Screenshot 2021-03-05 at 09.30.36

We have also notified our web team to update the instruction page to be inline with the latest version of GPG Services.

I hope this helps. However, should you require further assistance, please do not hesitate to contact us again.

In the meantime, thank you for bringing up the issue and once again we apologize for the delay in replying.

Kind regards,
Mior

2 Likes