Daedalus Wallet Linux problem

daedalus

#1

Hey,

i use the daedalus wallet on two machines. Laptop with intel cpu works perfect.
On my AMD64 Desktop i cannot start the wallet. Here is the output im getting:

‘/bin’ -> ‘/nix/var/nix/profiles/profile-mainnet/bin/’
‘/etc/protocols’ -> ‘/nix/store/s4ns0y7nnqvjyzy0n99chbml2n6xvzl7-iana-etc-20180108/etc/protocols’
‘/etc/services’ -> ‘/nix/store/s4ns0y7nnqvjyzy0n99chbml2n6xvzl7-iana-etc-20180108/etc/services’
‘/etc/ssl/certs/ca-certificates.crt’ -> ‘/nix/store/y1la7mv3b95ka3hbfk4p9hpmxbfv6kka-nss-cacert-3.34.1/etc/ssl/certs/ca-bundle.crt’
‘/etc/ssl/certs/ca-bundle.crt’ -> ‘/nix/store/y1la7mv3b95ka3hbfk4p9hpmxbfv6kka-nss-cacert-3.34.1/etc/ssl/certs/ca-bundle.crt’

  • test -z ‘’
  • XDG_DATA_HOME=/home/hammer/.local/share
  • export CLUSTER=mainnet
  • CLUSTER=mainnet
  • export DAEDALUS_DIR=/home/hammer/.local/share/Daedalus
  • DAEDALUS_DIR=/home/hammer/.local/share/Daedalus
  • export DAEDALUS_CONFIG=/nix/var/nix/profiles/profile-mainnet/etc
  • DAEDALUS_CONFIG=/nix/var/nix/profiles/profile-mainnet/etc
  • mkdir -p /home/hammer/.local/share/Daedalus/mainnet/Logs/pub /home/hammer/.local/share/Daedalus/mainnet/Secrets
  • cd /home/hammer/.local/share/Daedalus/mainnet/
  • exec /nix/store/v6w6zvjvjs47sa8hk83y7d50v40cvwvl-cardano-daedalus-bridge-2.0.0/bin/cardano-launcher --config /nix/var/nix/profiles/profile-mainnet/etc/launcher-config.yaml
    [cardano-sl.launcher:Info:ThreadId 4] [2019-01-20 13:54:54.24 UTC] using configurations: ConfigurationOptions {cfoFilePath = “/nix/var/nix/profiles/profile-mainnet/etc/configuration.yaml”, cfoKey = “mainnet_wallet_linux64”, cfoSystemStart = Nothing, cfoSeed = Nothing}

Nothing appears afterwards. I tried in VirtualBox on same desktop in a windows environment and the wallet is working there - so it has nothing todo with my old AMD Phenom X4 CPU (i thought maybe i miss some CPU features)

Any ideas here?

Regards,
Marcus

Infos: I use a Debian system based on 18.04 ubuntu here (elementary os 5)


#2

I am running a VM of Ubuntu 18.04 on virtual box and Daedalus works fine on that. Is it possible there is a difference in how the Debian version of Linux handles the /home/hammer directory? I don’t know. Maybe @rdlrt Priyank can help.


#3

Hi There,

I see there is a similar issue open on github, but does not have much details.

  1. Could you run the below and share /tmp/output.log (do a ‘sudo yum -y install strace’ if strace is missing):
    strace -o /tmp/output.log ~/.local/bin/daedalus-mainnet
  2. Also, Is it possible for you to share the log files from the following folder :
    /home/centos/.local/share/Daedalus/mainnet/Logs/pub

Lastly, if you’re on telegram, could you hit the @CardanoCommunityTechnical group?


#4

This post was flagged by the community and is temporarily hidden.


#5

Thx @Octalus ,
Unfortunately I forgot to add a follow tag to strace , could you re-run strace with a -f parameter?
Also, are you on telegram ? We may have to run some tests interactively…You can find me in https://t.me/cardanocommunitytechsupport group


#6

This post was flagged by the community and is temporarily hidden.


#7

It appears that a non-optimized library version is being loaded.

Can you run apt and update your system?


#8

i do this every few days on my system.
Which library is problematic and can i try to reinstall it somehow? maybe with another installation it went bad?

-> upgrade system does not change anything here
-> also tried the new 0.12.1 release without changes


#9

Did you have to run:

sudo sysctl -w kernel.unprivileged_userns_clone=1
sudo echo kernel.unprivileged_userns_clone=1 > /etc/sysctl.d/nix-user-chroot.conf

Before installing?


#10

Hey,

no this was not needed Todo for a successfull Installation so far.
Should i try a reinstall including this command before it?

Makes no difference, tried it.

–> Which library is problematic?


#11

Sorry about the delay, I do not get notified when someone posts.
Can you verify that your coprocessor has been recognized by your OS?
Also, looking at your logs, does this location exist?

/home/hammer/.local/bin/daedalus

If it does make sure you own those locations, user and group, you should be the one running the app.


#12

Hey,

so i checkt the .local/bin and yes it is there and i own it as user.
For the co-processor thing i’m not sure how to find it out - i printed an ‘cpuid’ output to a text file. Here everything for my cpu should be inside i hope.

https:/www.dropbox.com/s/erhxou0wo7koib0/cpuid.txt?dl=0

The fact that the daedalus wallet is working in a windows VM on base of the same system shows me that it is not a problem of the cpu capabilities i think.

Regards
Marcus