Daedalus Wallet Stuck on "Connecting to Network"

I try to air gap all my wallets, so having the Daedalus wallet seemed like a great solution. However, you are correct it is very hit and miss as to whether the wallet will make if past the “Connecting to network” stage and if it doesn’t and just spins you are locked out. Some things to check

  1. Your clock is acurate
  2. The Daedalus executable is registered on Windows as a network allowed program in the firewall settings

Even then the wallet is not guaranteed to connect, so just try restarting it and leaving it until it does

HOWEVER! This brings me to a more serious issue and that is access time. I have decided to shift all my ADA back into my Bittrex account where it is far from safe, but I am concerned that one day I will simply not be able to connect locally and am locked out from managing my coins. Also the block sync time is getting ridiculous. If I fail to log into my wallet daily it can take over an hour just to get logged in. This IS NOT a viable wallet interface

7 Likes

@joneyre i agree and for me i cant get on at all to even move my ada if I wanted too.

1 Like

You have to be patient. Deadalus has to go trough the whole blockchain. It may take up to 45 min.

3 Likes

Sorry to hear you’re having issues with the network.

Did you see IOHK put out a statement on connection issues: IOHK statement: connecting to network issue

Hopefully this helps! :blush:

I’m really livid right now at these guys(The whole Cardano Team). They should simply decommission this ineffective wallet. Why jeopardise peoples hard earned investment with a half baked wallet. If they can’t get it right, there is no shame in partnering with someone( with good track record) in providing Wallets that are reliable and safe.
Using us as guinea pigs isn’t the best and it doesn’t speak well of the Cardano’s mgt as being credible people, when they can’t own up to minor issues.

My coins are on Bittrex for days and i can’t move them, please give us another wallet to work with since yours is epileptic.

By the way, i tried this suggestion it’s not working.

Mac

  1. Quit the application
  2. Click the clock that is located on the top right of the screen
  3. Select Open Date & Time Preferences
  4. Unlock the preferences
  5. Uncheck the Set date and time automatically
  6. Restart the application

Thanks.

3 Likes

Hi,
@Mitchell_R_Kirkpatri @elsorn @markljenkins
I was having the same connecting to network error for days and was also very frustrated and I agree that the wallet needs work, but I was able to fix it.

I noticed that the log file in C:\Users\MyUserName\AppData\Roaming\Daedalus\Logs was over 250MB.

I shutdown the wallet and also killed the cardano-node process that was left running in task manager.

I deleted all the logs in the Logs directory (it would probably have been a better idea to move them to another folder)

When I restarted Daedalus, it synced with the network and opened!

Let me know if this helps.

6 Likes

Alright my wallet does work now. I left it running all night and while at work then finally connected. Now I can open and close it at any time I want too

2 Likes

first connect takes a while, after that it take seconds to sync. I think it would be good practice to open your wallet once a day.

1 Like

Greetings,
I Am Having Trouble With My Tokens Not Showing Up In My Daedalus Wallet. I Sent Tokens Yesterday And The Day Before And It Worked Fine. Today No Such Luck. I Have Double Checked The Wallet Address Multiple Times And Its A Match. 1000 Ada missing. Please assist.

Ok, it has been reported that some people can fix connection issues by deleting the log files (not the folder but insides) and restarting daedalus. If anyone tries this, please report back.


Instruction on the site.

3 Likes

I solved my issue the following way (I’m on a Mac btw).

  1. Quit Daedalus (if open)
  2. Open Finder, press CMD+SHIFT+G,
  3. Enter this: ~/Library/Application Support/Daedalus/Wallet-1.0, and click GO.
  4. Delete the file called open.lock
  5. Open Daedalus
3 Likes

I have the same problem not yet solved, opening daedalus I see the icon and the message “Connecting to network”.

Operating System: Windows 10
Daedalus Version: 1.0.3769
Daedalus about Version: 0.8.2
Blockchain: fully downloaded
Content of cardano-node.log:
[node. worker. us:DEBUG:ThreadId 39648] [2017-12-12 21:22:31 GMT Standard Time] Updating slot for US…
[node .worker. slotting.slotting:NOTICE:ThreadId 39649] [2017-12-12 21:22:31 GMT Standard Time] New slot has just started: 21533rd slot of 15th epoch
[node. worker. us:DEBUG:ThreadId 39648] [2017-12-12 21:22:31 GMT Standard Time] Checking for update…
[node. plugin. tx. resubmitter:INFO:ThreadId 39650] [2017-12-12 21:22:31 GMT Standard Time] Transactions to resubmit on current slot: []
[node. worker. us:DEBUG:ThreadId 39648] [2017-12-12 21:22:31 GMT Standard Time] There are no new confirmed update proposals for our application
[node. wallet. servant:INFO:ThreadId 39658] [2017-12-12 21:22:31 GMT Standard Time]
GET
:> api
:> settings
:> sync
:> progress
Status: OK 0.0019931s > progress=341795/ peers=0
[node.wallet.servant:INFO:ThreadId 39655] [2017-12-12 21:22:31 GMT Standard Time]
GET
:> api
:> settings
:> sync
:> progress
Status: OK 0.0019863s > progress=341795/ peers=0
[node.wallet.servant:INFO:ThreadId 39669] [2017-12-12 21:22:33 GMT Standard Time]
GET
:> api
:> settings
:> sync
:> progress
Status: OK 0.0010207s > progress=341795/ peers=0
[node.wallet.servant:INFO:ThreadId 39666] [2017-12-12 21:22:33 GMT Standard Time]
GET
:> api
:> settings
:> sync

Content of daedalus.log:
[2017-12-12 21:24:21:0331] [debug] Local difficulty changed: 341795
[2017-12-12 21:24:21:0331] [debug] Network difficulty changed: null
[2017-12-12 21:24:22:0242] [debug] Local difficulty changed: 341795
[2017-12-12 21:24:22:0242] [debug] Network difficulty changed: null
[2017-12-12 21:24:23:0243] [debug] CardanoClientApi::syncProgress called
[2017-12-12 21:24:23:0254] [debug] CardanoClientApi::syncProgress called
[2017-12-12 21:24:23:0365] [debug] CardanoClientApi::syncProgress success: {
"_spLocalCD": {
“getChainDifficulty”: {
“getBlockCount”: 341795
}
},
"_spNetworkCD": null,
"_spPeers": 0
}
[2017-12-12 21:24:23:0366] [debug] CardanoClientApi::syncProgress success: {
"_spLocalCD": {
“getChainDifficulty”: {
“getBlockCount”: 341795
}
},
"_spNetworkCD": null,
"_spPeers": 0
}
[2017-12-12 21:24:23:0366] [debug] Local difficulty changed: 341795
[2017-12-12 21:24:23:0367] [debug] Network difficulty changed: null

I tried to remove everything from appdata/Roaming/Daedalus, I reinstalled the application, I left the wallet on for a day but no success.

Can anyone help?

Thanks

UPDATE: I restarted my machine and left the Wallet hanging on that page and now it is started asking to create or restore a wallet.
I started the restore, let’s see how long it takes to have it functional.

UPDATE2: After starting the Wallet restore, I waited 8 hourse with no success, I closed and opened the walled again and it got stuck another 8 hours “connection network”. I might give up no…

Thank you!

Same issue here happened after update. Deleting the blockchain partially solve the problem as it allows deadalus to resync. So it’s not a connection issue. But once closed and relaunched, the issue is still there. So for now, I have to delete the blockchain every time I want to use the wallet and resync the whole thing.

@markljenkins his solution worked for me as well. I’m on Windows10

  • uninstall Daedalus
  • i deleted the entire folder from C:\Users<username>\AppData\Roaming\Daedalus
  • redownloaded installer from https://daedaluswallet.io/#download
  • reinstalled (no errors, never had any but just made sure :slightly_smiling_face:
  • opened Daedalus

and now it’s syncing again… how it keeps working! strange though… didnt change any timesettings or anything…

@Godspeed Did it several times, it completes the sync then asks to create or restore wallet.
Mine get stuck after trying to restore a wallet and after restarting daedalus will show the usual “connecting to network”

@norcino well, i created a new wallet, to gift some ADA to a friend… i deleted it to try and restore it… i had the same thing. Restoring took ‘forever’ so i cancelled it and then i couldn’t connect anymore…

did you do something similar before it stopped working for you? it’s still working for at least 2 of my friends, but on my home desktop and work laptop it doesnt… even on different networks (doesnt matter since it wants to connect to 127.0.0.1)

@Godspeed I tried to move the data folder containing the blockchain to another partition. My C: drive is an SSD drive and I wanted to use an HDD to store all blockchains I have for various wallets.
I never managed to get it working, so I reverted my changes, reinstalled everything and deleted appdata folder but no success, no Idea.
Just to give you more info that might be useful to find common patterns, in my machine I normally have CPU and GPU mining active, but I don’t think that this would cause the wallet to get stuck for hours… also because I have plenty of CPU power available even while mining.

thank god i bought mine on a exchange and there still there … looks like il just sell off what i have until they sort this out , sort it out fast people need this working

Three times i uninstalled , deleted all file from Appdata and installed. Always giving me “Unable to connect” failure. Cant even restore my wallet. My coins stucked at wallet. What a headache. Please solve this problem. I had to stop investing more, i dont wanna keep coins at market.