Daedalus, "Connecting to network..." STUCK FOR DAYS

daedalus

#1

So, a lot of people are having this issue. Their wallet cannot connect to the network, and if it can, often - it has trouble syncing. I’ve been checking my Daedalus wallet daily for about three weeks, it was working fine until the past few days. And for no reason, it bugged out. There have been no discernible changes on my system. There have been no firewall, antivirus, or connectivity changes on my machine. I’ve tried every available “fix” posted on help sites, and Reddit forums. None of them work. This is a major issue that is happening to a lot of people.

I have my recovery passphrase. Is this something worth reinstalling and using my passphrase for?


#2

Have you tried launching the software without using a shortcut or pinned taskbar button?

Use the included .BAT file installed.


#3

This worked for me, thank you very much. I had tried setting rules in the firewall and some other things before reading your comment :smiley:
I think it would be nice if the developers put somewhere clearly that the user must use the .BAT file and not the .EXE to launch the client. (Maybe that’s already stated somewhere, but I didn’t see it)