My Daedalus Wallet is stuck on "Connecting to Network"


#1

Hey guys! Just wondering if anyone else is experiencing this issue please let me know how to go about fixing it!
THANKS IN ADVANCE!


#2

Have you followed the FAQ? https://daedaluswallet.io/faq/

If you’ve done that - there are some simple next steps.

Note that it can be in this state for several minutes (especially if this is the first use of a wallet or the wallet has been offline for a substantial time).


#3

Open Deadalus and be patient.


#4

I’ve had my wallet for quite some time already lol. and the last time it was open was only 2 days ago.


#5

The next two most likely things are:

  1. there is an instance of cardano-node running (stop dedalus then check with something like ps aux | grep cardano) - obviously rebooting the system is sure way to make sure a process is no longer running
  2. Is there something else running on port 8090 on localhost? (netstat -ln | grep 8090) - though you say that it has worked before - so unless you’ve installed something lately that is not likely to be the case.

If you have it “syncing” you can see which peer node it has chosen with netstat -ln | grep 3000


#6

“I just downloaded the wallet early yesterday morning. I’ve never got it past the “Connecting to network…” stage.
I’ve done everything mentioned in the latest IHOK Statement: IOHK statement: connecting to network issue about this problem after I followed all of the advice in the FAQ. I’ve checked for port clashes… None. I’ve checked for node running in background… no go. I’ve reinstalled it at least three or four times after uninstalling it. I’ve erased all logs files in the appdata folder in numerous sequential steps. I’ve made exceptions in my virus protection to allow for both node and Daedalus executables. I’ve checked my firewall settings and nothing appears to be amiss. I’ve used both VPN and regular windows network formats. I’ve sinc-ed the internet clock in all of its settings. None of these things have worked for me. I’ve let it run all night hoping it would sinc… no go. The facts may be unkind but I’m trying very hard not to be. I’ve also sent a bug report including my Logs.”

Update: Everything is working fine now. Found that if the following sequence is strictly adhered to the results will most likely be positive. This is what I had to do after numerous attempts. Save yourself some trouble. The wallet is pretty nice once you get it working. 1. If you’ve already installed it improperly then you need to delete the daedalus folder in %appdata% under roaming. 2. After that uninstall daedalus. 3. Restart the computer to make sure everything starts fresh with no binding dependencies before you reinstall the program. 4. When you restart the computer you will also have to resync the clock. Do this before you reinstall. 5. Then run the program from either the bat file directly or from a shortcut to it. I used “elevated” or administrator rights to install the program. It took between forty-five minutes to an hour to fully sync the blocks. Works like a charm!


#7

Check out this post even if you are on Windows the thinking is the same, only the paths change: (Daedalus infurating to use on OSX)

Cheers


#10

Windows or Mac?

If Mac run this from terminal to sync time:

sudo ntpdate -u time.apple.com

The end of that output will tell you how far off your time was.

12 Dec 14:32:03 ntpdate[1622]: adjust time server 17.253.4.253 offset 0.001825 sec

Example, I was off by 0.001825 sec


#13

Do your logs also show something like below?

“message”: “connect ECONNREFUSED 127.0.0.1:8090”,
“code”: “ECONNREFUSED”,
“errno”: “ECONNREFUSED”,
“syscall”: “connect”,
“address”: “127.0.0.1”,
“port”: 8090


#14

C:\Users[username]\AppData\Roaming\Daedalus\Logs\Daedalus.log


#18

I was having the same problem. It was solved when I discovered I had several downloads of the wallet and was working with an older version of the wallet. I removed/deleted all previous versions, downloaded the most recent version, the wallet connected, then I had to leave it on overnight while it sync with the entire blockchain. Now it opens immediately and is functioning the way it should.


#19

am experiencing the same thing too, for 2 days now it still saying connecting to the network