Issues with restoring wallet


#1

Hello. I recently deleted my wallet for security issues and it had ADAs stored in it. I have been trying to restore it using my phrase and password but nothing happens. Wallet was working perfectly fine before deleting and now it just shows: Connecting to network…

Can I please get some help? Have tried uninstalling and reinstalling it and still shows stuck on the connecting…

Thanks in advance.

Kerix


#2

I had this to. When restoring your wallet, it has to go trough the whole blockchain again. So you have to be patient. It can take up to 45 min. Or a bit longer. If you closed Deadalus to early, just open Deadalus and wait. Eventually it will restore your wallet. Just be patient.


#3

Well I didn’t know… I ended up closing during the process and now when I try opening it again, it is just stuck on “Connecting to network”… Has never taken this long to go through. Any ideas?

Tried restarting, tried reinstalling and nothing… Just stuck now completely :frowning:


#4

It didnt stuck. Just be patient. Open the wallet and let it go trough the blockchain. It is working even if it says ‘Connecting to network…’ Just make sure you are connected to the internet.


#5

@Kerix If it still doesn’t work after a while, maybe have a look at the instructions here https://daedaluswallet.io/faq/


#6

Oh ok… Guess I’ll wait longer then… It’s been like 15mins but still Connecting… I’ll just wait it out. Thanks for the help and your time. Really appreciate it!


#7

@CosmosX just did… Tried updating the time etc as stated in the faqs but no luck yet. I guess I’ll just wait a little longer as Ghost mentioned above. Thanks a bunch Cosmos!


#8

Took a long time but finally got it back… Thanks for the help guys!