Stuck in "restore wallet"


#1

I made a clean install of Daedalus. I clicked on “restore wallet”, and typed in my recovery phrase. It’s stuck. The little spinning wheel on the restore button is still spinning. It’s been 10 minutes.


Why does restoring the wallet from passphrase take so much time?
#2

Yes, the restore feature was not optimized. Apologies, but you have to run the restore for a long time. If you shut down the app during the restore, it might cause issues and you may need to reinstall. It was one of those things that in testing when the chain was shorter worked great, then suddenly it became a problem.


#3

Thanks. I’ll try leaving it for a couple of hours. Will it be faster eventually? And will you add. some kind of progress bar so users know it’s working on it?


#4

The team cleaning up and optimizing things doesn’t have a public roadmap. Sorry.


#5

Same problem - should be pushed to the front on wallet dev list imho


#6

Having a myriad of issues surrounding connection issues with my wallet. This being one of them. It seems like I’m running into literally every problem this wallet has all at once. Seemingly worked fine, transferred funds to it, but then the outgoing transactions were stuck, for days. They didn’t even post to the blockchain.

Deleted, tried to restore, thought it was stuck so I reloaded, which broke it, continuously told me my wallet already existed…

Reinstalling for a third time now. This time I’m searching my PC for everything with the name “Daedalus”, “ADA”, and “Cardano” and deleting before running the install file. Going to reboot and resync the clock. Again. Hopefully will not get stuck in “Connecting to network”.