Daedalus wallet update

In case you are interested, here’s the blog post about the update: https://cardanofoundation.org/press/cardano-1-1-0-software-update/ :slight_smile:

1 Like

Just installed it and it works well. Daedalus opens within a minute, whereas before it to about an hour… Thanks!


Trying to install on macOS i got error but the same as i had first time installing wallet the workaround was clean reboot then the installation went fine.

Only issue now its trying to connect to the network for more then 10 minutes, do not know if that is normal a button appeared on the top saying “Having trouble connecting to network?” Report an issue.
Shall i wait or report it?

UPDATE: i have reported it with attached logs, logs are full with this message, which is strange why connecting to

[2018-03-08 09:56:26:0010] [debug] Connection Lost. Reconnecting…
[2018-03-08 09:56:26:0921] [debug] AdaApi::syncProgress called
[2018-03-08 09:56:26:0927] [error] AdaApi::syncProgress error: {
“stack”: “Error: connect ECONNREFUSED\n at Object.exports._errnoException (util.js:1050:11)\n at exports._exceptionWithHostPort (util.js:1073:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)”,
“message”: “connect ECONNREFUSED”,
“errno”: “ECONNREFUSED”,
“syscall”: “connect”,
“address”: “”,
“port”: 8090

Seems the report server is in Germany

The only thing that the wallet connects to is:

IP Address:
Country: United States
Country Code: US (USA)
Region: Texas
City: Irving
Local time: 08 Mar 00:57 (CST-0600)
Postal Code: 75063
Latitude: 32.9193
Longitude: -96.982

Still nothing is happening, Connecting to network…

Ok i fixed the issue, i discovered the following thread

In which they mentioned deleting the Logs directory, so what i did was stopping the wallet app then moving the Logs to Logs.old which on Mac you can find under "cd /Users/your username/Library/Application\ Support/Daedalus/

mv Logs Logs.old
restart wallet
It will ask you for language again etc accept and sync starts, within a few minutes i had my wallet open all ok.

What OS are you on? Did you ever tinker with the files yourself?

As you can see i use MacOS and no i never have changed anything before till i run into the issue i had now, but is now solved by moving the Logs directory, seems that this workaround worked for more users on different OS.

Oke great! However keep in mind that this action might cause problems with another upcoming update so still try to find a better solution if there is one, but for now cheers

I have the same problem. Hit the update button from within the wallet and it installed and now the .bat file won’t even launch the wallet.

Just found the issue. Don’t try to run the new wallet with the .bat file. Use the shortcut that it created on the desktop. Worked pretty fast and is now updated.

1 Like

This just worked for me too. Thanks a lot! :smile:

@RobJF Did you ever find a solution to your problem with the Daedalus.bat? I too am having the same issue. It had been launching just fine until I upgraded to the latest version and now it fails silently. Upon examing the cli-parse.error.log, it states “Invalid option `–updater-windows-runner’” . There are no non-alphabetic characters in the user name or path. I also tried renaming the AppData Daedalus folder and reinstalling, but no luck. Hoping you found the answer.

Use Daedalus.exe cardano-launcher.exe
(Updated, wrong .exe name, sorry. Kudos to @RobJF)

1 Like

The answer is in the post just above your’s. Shortcuts targeting Daedalus.bat no longer work, the target should be cardano-launcher.exe. In typical installations, the one on the desktop should be correct.

1 Like

hi people,

i have osx 10.9.5. require a wallet download for my system as new update cannot be installed.

where can i find the correct download for my version of osx please?