Empty topology.json (api.clio.one)

I am using CNTools and $CNODE_HOME/files/topology.json is empty. I ran $CNODE_HOME/scripts/topologyUpdater.sh manually to see what the issue is and I am seeing this error:
ERROR: The downloaded file is empty!

Looking through the topologyUpdater.sh script I see this error message here: guild-operators/topologyUpdater.sh at a38c7c108787cf8963803bf04e96f1ec908cc2b6 · cardano-community/guild-operators · GitHub

This lead me to check if api.clio.one is down.

Am I doing something wrong? I’m in the process of upgrading to 1.34.1 and the upgrade is failing to restart since I have a now empty topology.json file. Is it normal for api.clio.one to go down?

Nothing has changed :thinking:

try sudo systemctl | grep cnode-tu-

I found the process… stop it

  • cnode-tu-fetch.service : fetches a fresh topology file before cnode.service file is started/restarted

sudo systemctl stop cnode-tu-fetch.service

add few nodes manually inside the topology file and restart the nodes

But now it looks like the site is up/online again

Yeah, sure enough. It’s back up. Weird…

Thanks @Alexd1985 !

1 Like

There was a DNS resolution problem with api.clio.one. Has been solved by now.

1 Like

Thank you!