Error building cardano-node from source

Hello,
I am trying to build a node from source following the guide Installing cardano-node and cardano-cli from source | Cardano Developer Portal

But I am running into compilation errors and the build fails with the following message:

cabal: Failed to build cardano-ledger-byron-test-1.3.0 (which is required by
test:cardano-api-test from cardano-api-1.29.0 and test:cardano-cli-test from
cardano-cli-1.29.0). See the build log above for details.
Failed to build plutus-core-0.1.0.0 (which is required by exe:plutus-example
from plutus-example-1.29.0, test:cardano-api-test from cardano-api-1.29.0 and
others). See the build log above for details.

(See uploaded output here: Zefiro

As per the doc, below some info on my build environment:

Linux cardano 5.4.0-84-generic #94~18.04.1-Ubuntu SMP Thu Aug 26 23:25:08 UTC 2021 i686 i686 i686 GNU/Linux

ste@cardano:~$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 8.10.4

ste@cardano:~$ cabal --version
cabal-install version 3.4.0.0
compiled using version 3.4.0.0 of the Cabal library

ste@cardano:~/Cardano/cardano-src/cardano-node$ git describe --tags
1.29.0

I searched the forum, but could not find a case similar to mine. Any help is very appreciated, thanks in advance.

For testnet or for mainnet?

Is this a 32bit or 64bit OS ?

Asking as according to the error it seems like it’s a 32bit OS and I believe you need a 64bit to be able to compile.

Hi Nik, it is 32bit… I was wondering since it has been ported to raspberry, it should work on a 32bit pc … maybe I was too optimistic? I could not find any limitation in the documentation and the build should not even start. I still hope it can be fixed …

I believe people use RP 3 or 4 with 64bit OS, but don’t take me for granted as I haven’t tried compiling on RP and 32bit systems. Use the info as a starting point for further research.
The error sounds like that is the problem as the numeric values are out of bounds. Btw just to mention you’ll need 16GB RAM to be on the safe side.

You need a 64 bit architecture, 32 bit won’t work.
Rpi 4 is 64 bit capable, we run a 64 bit OS

Hi, thanks for this. Do you believe this is a intrinsic requirement for cardano or just lack of focus on 32bit systems?

I actually found this thread Cardano Node 1.24.2 Installation Cabal Build not creating the dist-newstyle/build/* files Ubuntu 18.04 32bit

which seems to be encouraging (i.e. not a architecturale requirement) let’s see if it takes me somewhere :slight_smile:

Let us know how it goes, but as I said you will need at least ~10GB RAM for mainnet and not sure how that will work with a 32bit OS?

tag 1.24.2 did not work either; I tried 1.25.0 and I’ve got the same error with length of an integer…
I guess there is no way to build on 32bit :frowning:

You may have a better luck getting help if you spell out exactly what you are doing along with the output you see from the very beginning. If it’s too long, post a github gist and link it here. Same for all log files that are mentioned in the output: post them somewhere (in the same gist as separate files?) and link.

Hi Keith,
thanks for taking the time to looking into it. You find the information you asked in the very first post for this issue. In particular I uploaded the logs here Zefiro . I also described what I am trying to do (which is just installing a node following the instructions on a 32bit system). I’ll be very happy to provide more information if you need anything else.

Regards