Error while submitting tx.signed Help

Hi All,
I am getting the below Error when submitting my signed tx.signed. Can someone please help. I checked everything on the server side all looks fine. Command used is from CoinCashew

cardano-cli transaction submit
–tx-file tx.signed
–mainnet

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraMary (ApplyTxError [UtxowFailure (UtxoFailure (OutsideValidityIntervalUTxO (ValidityInterval {invalidBefore = SNothing, invalidHereafter = SJust (SlotNo 266387)}) (SlotNo 37585837)))])

This is actually a common mistake that SPOs fall into. Submitting your signed transaction won’t work unless the invalid-hereafter value is greater than the current tip.

So for example, you built your tx.raw on your BP, then decided to pause. Later on you continued the process and tried to sign the transaction…etc. That won’t work, because the tip will be higher than the invalid-hereafter, and the transaction fails.

DevJohn
Could you define these acronyms?
_SPO
_BP

Thanks

SPO Stake pool operator
BP ?

Block Producer

Got it, thanks

My testnet transaction build/sign/submit worked, using the correct TX HASH and TX IX.

1 Like

Hi DevJohn
so how can I make it work ?