Failed withdrawing rewards of returning pool registration deposit with MissingVKeyWitnessesUTXOW

I registered a stake pool at epoch 237 and retired at epoch 238. In order to withdraw returned rewards into the reward address, tried to make a transaction thru the instruction. But it failed with the MissingVKeyWitnessesUTXOW error.

cardano-cli transaction sign \
--mainnet \
--tx-body-file withdraw_rewards.raw  \
--signing-key-file payment.skey \
--signing-key-file stake.skey \
--out-file withdraw_rewards.signed

cardano-cli transaction submit \
--mainnet \
--tx-file withdraw_rewards.signed

Shelley command failed: transaction submit Error: Error while submitting tx: ApplyTxError [LedgerFailure (UtxowFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “ef5096dbe8818da93ec4050899d1d5005178b93aa01d193a0e881178”]))))]


It’s in the error… missing VKey file


How could it be missing even if it’s registered? link.

I am talking about this file kes.vkey should be on your server while perform the transaction

I’m not following you. Could you let me know why the server needs KES vkey for withdrawing rewards?

sorry, my bad, I reviewed the guide and indeed, there is no need…

did u follow this guide?

18.11 Claim your rewards

Just solved. The error message was unclear. By some reason, the payment key pair was refreshed. So I restored it from a backup and worked well.

1 Like

Hello, I want to make it clear, does it mean that after i retire the stakepool, i dont need to claim? And it will return by it self??

Nope, the 500 ADA will return to you as a reward, so u will need to withdraw the rewards first and after that remove from the wallet (send to another wallet)