Unable to claim rewards after pool retired

I have retired my pool during epoch 273. After 274 was completed, my pool showed as retired and my stake address now has 500 ADA. I am using the CoinCashew Guide 18.11 Claim Your Rewards Guide: How to build a Cardano Stake Pool - CoinCashew
Everything goes very smoothly until I try to submit the transaction and get the following error message.

cardano-cli transaction submit --tx-file tx.signed --mainnet

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraMary (ApplyTxError [UtxowFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “273332da8d83602697d3e192be4193dcf2575f6d80307684506a9bab”])))])

Where did I mess up? And how do I fix it?

The node is synced, also do u have all wallet files on the server? I think u are missing one as the error says

Someone fixed by:

“Just solved. The error message was unclear. By some reason, the payment key pair was refreshed. So I restored it from a backup and worked well.”

I have gone back and tried to submit with the keys that were in the trash. Still having the same error. I have tried to submit the transaction several different ways, and always the same error.
That KeyHash is from the stake.addr “Stake Address Registration Certificate”
However the cborHex in the stake.cert is 82008200273332da8d83602697d3e192be4193dcf2575f6d80307684506a9bab.

I have the older keys and the newer keys. For some reason, neither are working. You had me create a new stake.cert while trying to resolve something else a few weeks ago. Would this cause problems with collecting the rewards back?

Phew idon see through