Help on retiring my stake pool

Hey guys,

I’ve decided to retire my small stake pool since its not getting anything after 42 epochs.

I have followed this guide successfully:

But I get an error after I submit it on the mainnet:

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutsideValidityIntervalUTxO (ValidityInterval {invalidBefore = SNothing, invalidHereafter = SJust (SlotNo 44621850)}) (SlotNo 45943096))))])

I have tried updating to cardano-node 1.31.0 but still get the same error.

I have 100219875 lovelace on my pool. My guess is that it is not enough to proceed with the transaction?

I’ve also sent 5 ADA to my payment.addr (if that is correct?) since yesterday, but its not yet showing. Not sure what to do next.

Please help me! Thank you…

The node is running? Can u share the glive output?

Sure, here it is:

    > Cardano Node - (Core - Mainnet) : 1.31.0 [2cbe3638] <

β”‚ Uptime: 17:25:32 β”‚ Port: 6000 β”‚ Guild LiveView v1.24.0 β”‚
β”‚ Epoch 304 [49.4%], 2d 01:54:38 remaining β”‚
β”‚ β–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ–Œβ––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β–– β”‚
β”‚ β”‚
β”‚ Block : 6541785 Tip (ref) : 47513122 Mem (RSS) : 8.2G β”‚
β”‚ Slot : 213351 Status : sync 97.2%Mem (Live) : 3.7G β”‚
β”‚ Density : 4.685 Forks : 0 Mem (Heap) : 8.2G β”‚
β”‚ Total Tx : 0 Peers In : 1 GC Minor : 195165 β”‚
β”‚ Pending Tx : 0/0K Peers Out : 1 GC Major : 870 β”‚
β”‚- BLOCK PROPAGATION --------------------------------------------------β”‚
β”‚ Last Delay : 1334966.73Served : 0 Late (>5s) : 136580 β”‚
β”‚ Within 1s : 0.00% Within 3s : 0.00% Within 5s : 0.00% β”‚
β”œβ”€ CORE ────────────────────────────────────────────────────────────────
β”‚ KES current/remaining : 0 / 0 β”‚
β”‚ KES expiration date : 2021-12-08 21:44:51 UTC β”‚
β”‚ Missed slot leader checks : 0 (0.0000 %) β”‚
β”‚- BLOCK PRODUCTION ---------------------------------------------------β”‚
β”‚ Leader : 0 Adopted : 0 Invalid : 0 β”‚
TG Announcement/Support channel: Telegram: Contact @guild_operators_official

[esc/q] Quit | [i] Info | [p] Peer Analysis

Status : sync 97.2%

Epoch 304… not synced, can’t be retired

Thanks Alex, what do you mean by this?

We are on epoch 307, your node on 304… it’s behind with 3 epochs

I wonder if it does catchup? Time is running on my end for decommissioning this server from a rack :frowning:

should be sync in the next hours (I think it will take 1-2 hours/epoch)

1 Like

Make sure you back up all the keys. You can always install the node locally or in the container and retire the pool.

1 Like

Hi Alex, thanks for your help on this. I’ve managed to retire my pool after epoch 313.

I am trying to transfer the funds from my stake address to my Daedalus wallet. I have followed the guide below:

However, I get nothing when I issue the first command:

a@vm01:~/cardano-my-node$ currentSlot=$(cardano-cli query tip --mainnet | jq -r β€˜.slot’)
cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)

a@vm01:~/cardano-my-node$ echo Current Slot: $currentSlot
Current Slot:

Can you please help?

you must export the socket first

echo export CARDANO_NODE_SOCKET_PATH="$NODE_HOME/db/socket" >> $HOME/.bashrc
source $HOME/.bashrc

but first type cd $NODE_HOME/db and check if the socket is there

1 Like

Thank you so much Alex! You have been a great help on my stake pool operator journey from start to finish.

I’ve managed to transfer the funds back to my wallet. However I cant zero it out, I left about 1682232 lovelace. I want to take it all back, how to do? I get the error below:

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutputTooSmallUTxO [(Addr Mainnet (KeyHashObj

hmm, I don’t know how, someone earlier had this issue also but after few attempts he succeeded to withdraw… so try few more time

As I understand you are transferring the tokens to another wallet and getting the error. Most probably the total amount does not cover the 1ADA transaction minimum + Fee. Maybe you can transfer 1 ADA to that wallet and then try to transfer all funds… sure you’ll have an additional transaction cost for that undertaking.

Thanks, so what i currently have left in summary:

Total ADA balance: 1682232
fee: 176589
Change Output: 0

After submitting, I get the same β€œCommand failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError…”

I tried transferring 1.6 ada, 1.5 ada, and 1 ada - just got the same error.

I suspect its going to be left out on my ex block producer node, and thats gonna suck.

I’ll try to do it again in a few hours time.

Its been more than 8 hours, restarted block producer node, still got the same error.

I really suspect that it cant be zeroed out?

Ok i see now. Do you have other native tokens in tx-in or just ADA? Maybe paste all the commands you are executing. Also let us know what is in --txt-in.