Generating Cold Keys on Air Gapped Device

Hello.

I am at the point in the stake pool setup where I need to generate the cold keys.
I copied my Cardano-Cli library from one of the relays and pasted it into the air gap device, /user/local/bin.

When I run this command, I get a message on the air gap device, “cardano-cli: error while loading shared libraries libsecp256k1.so”
cardano-cli node key-gen
–cold-verification-key-file node.vkey
–cold-signing-key-file $HOME/cold-keys/node.skey
–operational-certificate-issue-counter node.counter

Any ideas?

If you built your cardano-cli with 1.35.0 you should rebuild it at 1.34.1. 1.35.0 is only for testnet at the moment and it requires the 256k1 library. But for now, if you’re just setting up a stake pool you don’t need 1.35.0 to generate the cold keys.

I did use 1.35.0. Thank You.

You can try this, then rebuild cardano-cli before copy it to your air-gapped machine. It’s worked for me.

cd $HOME/git
 git clone https://github.com/bitcoin-core/secp256k1.git
 cd secp256k1
 git reset --hard ac83be33d0956faf6b7f61a60ab524ef7d6a473a
 ./autogen.sh
 ./configure --prefix=/usr --enable-module-schnorrsig --enable-experimental
 make
 make check
 sudo make install
 sudo reboot

Will do, thank you!