Air-gapped machine troubles - version ‘GLIBC_2.33’ not found

I’m using the coincashew guide to register a stake pool but I’m stuck at the moment.

Whenever I enter this command on the air-gapped machine.

*> cardano-cli node key-gen *
*> --cold-verification-key-file node.vkey *
*> --cold-signing-key-file node.skey *
> --operational-certificate-issue-counter node.counter

It gives me an error which says “cardano-cli: /lib/x86_64-linux-gnu/ version ‘GLIBC_2.33’ not found (required by cardano-cli)”

How am I supposed to fix this problem without any internet to get “GLIBC_2.33” I thought the whole point of this machine is that the internet has never touched it so it stays secure.

Thanks in advance,


1 Like


How did you get cardano-cli? Downloaded or compiled?

I copied the cardano-cli from my block producer node and pasted that in the air-gapped machine.

If you compiled that cardano-node - maybe better not to copy it, if the other system is not identical - download the executable from official github page, and try that:

I followed this tutorial and everyone worked fine but the problem is that I don’t have all the files required (GLIBC_2.33) for the cardano-cli to start making keys on my air-gapped machine.

He only said to copy the cardano-cli file to the /usr/local/bin and that worked fine but the problem is after that when I try this:

“cardano-cli node key-gen
–cold-verification-key-file node.vkey
–cold-signing-key-file node.skey
–operational-certificate-issue-counter node.counter”

What is the error’s message?

Screenshot from 2021-06-20 10-18-10

Did not work sadly

What version of ubuntu are u using?

Ubuntu- on the air-gapped machine

Try to install build-essential which contains the glibc library…

sudo apt-get install build-essential

I know it is an air-gapped machine but at this point it seems it is missing from basic Ubuntu

Didn’t work either, I tried all of the following:

“sudo apt-get update -y”

“sudo apt-get upgrade -y”

“sudo apt-get install git jq bc make automake rsync htop curl build-essential pkg-config libffi-dev libgmp-dev libssl-dev libtinfo-dev libsystemd-dev zlib1g-dev make g++ wget libncursesw5 libtool autoconf -y”

“sudo apt-get install libc6”

It didn’t work, it still says “cardano-cli: /lib/x86_64-linux-gnu/ version ‘GLIBC_2.33’ not found (required by cardano-cli)”

btw, what is the output of ls -l /lib/x86_64-linux-gnu/

No such file or directory

hmm - maybe it is installed somewhere else - try to find the binary:
find / -name ""

Screenshot from 2021-06-20 12-25-44

good - try to add this /usr/lib folder to the LD_LIBRARY_PATH, and run the cardano-cli again

Still got the same error :frowning:

hmm, interesting…
then make a symlink which will placed to the desired folder:
ln -s /usr/lib/x86_64-linux-gnu/ /lib/x86_64-linux-gnu/
make sure now you have the file:
ls -l /lib/x86_64-linux-gnu/
and start the cardano-cli