Moving cardano-cli to air gapped device

I’m messing around with starting up a staking pool, I can get the cardano node running on a Ubuntu 20.04.1 LTS device. That’s no problem. I’ve setup an air gapped RasPi 3 to hold my keys that’s running on Ubuntu’s 20.04.1 LTS RasPi OS. But when I copy my cardano-cli over and try to run it I get “cannot execute binary file: Exec format error”. I’ve tried a few different other RasPi os’s, latest raspbian and both 64 bit and 32 bit versions of Pi Ubuntu. I even tried updating the OS to see if that would do anything. Nothing :frowning:

Anyone else run into this?

You need to compile the codebase for an aarch64 Plattform (ARM CPU)
It’s not (yet) officially supported but there are ways and guides to do so.
Might look at and then build the cli only


Ahh okay, that would explain it. Thanks I will give that a try.

i am experiencing the same issue, but how did you solve it ? tks in advance for your response

what command do you use to run the executable for cardano-cli, because I’ve copied my cardano-cli folder over from my block producer but cant figure out how to install it. Do I need cabal? because I see i have a cardano-cli.cabal file in there which is the only thing that looks like a executable.