Attempting to change pool.cert but getting error message: "Cardano-cli : command not found" on air gapped machine

I’m attempting to change my pool fee by following step 18.4 on the CoinCashew guide but am stuck at the following command on the air gapped offline machine:

cardano-cli stake-pool registration-certificate \
    --cold-verification-key-file $HOME/cold-keys/node.vkey \
    --vrf-verification-key-file vrf.vkey \
    --pool-pledge 25000000000 \
    --pool-cost 345000000 \
    --pool-margin 0.00 \
    --pool-reward-account-verification-key-file stake.vkey \
    --pool-owner-stake-verification-key-file stake.vkey \
    --mainnet \
    --pool-relay-port 6000 \
    --pool-relay-ipv4 <MY PUBLIC IP ADDRESS> \
    --metadata-url <MY METATAG> \
    --metadata-hash $(cat poolMetaDataHash.txt) \
    --out-file pool.cert

Output: “cardano-cli: access denied.” I then tried the sudo command to override:

sudo cardano-cli stake-pool registration-certificate \

Output : “Cardano-cli: command not found.”

I then tried again by guiding the file path using this:

sudo /usr/local/bin/cardano-cli stake-pool registration-certificate \

Output: “cardano-cli: command not found”

Then, I tried copying a fresh copy of the cardano-cli and cardano-node from my block producer node to to my air gapped machine’s /usr/local/bin — same effect.

I’ve done this process multiple times without issue before I upgraded to 1.31.0 using this guide: Update Cardano Node to 1.31.0 - for Coincashew users

Any ideas as to why this is happening?

Have you given cardano-cli enough permissions on your cold gap machined? i.e. chown the file?

1 Like

Hey Jeremy, thanks for your reply.

I must have given those permission to the original cardano-cli when initially setting up the pool & air gapped machine, but perhaps the new (post-1.31.0 update) cardano-cli has not been given the proper permissions? Do you have any suggestions to fix this?

Jeremy,

I figured out what was wrong:

Right clicked my “Cardano-cli” > Properties > permissions > check “allow executing file as a program”

Thanks for pointing me in the right direction!

1 Like

No worries. For those finding this, given you need to copy cardano-cli onto your cold box via a pendrive, you need to “chown” the executable to allow you to execute it on your cold box.

http://manpages.ubuntu.com/manpages/trusty/man1/chown.1.html

1 Like