How to run full node of cardano in both testnet and mainnet for web integration?

daedalus

#1

I want to integrate ada in my web-project and i want to run full node of ada. How can i do this? i downloaded the cardano gui wallet for windows from the official site i tried sending get request on this but didn’t got any response https:// 127.0.0.1:8090/api/v1/addresses
when i changed https to http it gave me error, this server only recieves https request. What i am doing wrong?

i’m following this documentation https://cardanodocs.com/technical/wallet/api/v1/#tag/Addresses

Downloaded wallet from https://daedaluswallet.io


#2

What do you want to achieve?
The v1 API’s not been implemented yet in the official Daedalus.


#3

i want to integrate ada in my website just like exchanges integrated it. Like binance. So initially i want to perform all the api methods on Testnet and then on mainnet using windows server. If v1 is not implemented and v0 is deprecated then how can i achieve it?


#4

V0 is not deprecated in the current Deadalus…


#5

but deadalus is not giving response of api calls? how to integrate it in web?


#6

It does, as Daedalus frontend uses Restful API calls to retrieve data from the backend.
What data do you want to retrieve from Daedalus ( ur addresses)? In other case, I would recommend you to run a full node e.g. Explorer instead of using Daedalus.


#7

The current API address is :
https:// 127.0.0.1:8090/api/v0

Daedalus is still using the V0


#8

@Omar_Hachami i sent a get request to https://127.0.0.1:8090/api/v0/accounts which should give me info about accounts in wallet but i got could not get response? its like nothing is listening on that port? Did the deadalus gui wallet for windows(https:// daedaluswallet.io) process all api request?


#9

@_ilap How can i run a full node, I actually want to run a full node but didn’t got any solution of how to run. so i found https:// daedaluswallet.io that link and thought may be it is the full node which will process all api calls like generating addresses, send transactions, accounts balances, info whatever a blockchain have.


#10

Start with this


#11

it also referring to daedaluswallet.io but again the problem is api calls.


#12

https://cardanodocs.com/technical/wallet/api/v0

Node responds perfectly when you send valid requests


#13

i sent valid request according to the documentation too but didn’t got any reponse.

Let suppose in v0, to get list of accounts there is url https://127.0.0.1:8090/api/accounts to get response, when i hit that url i got nothing. i think there is some issue in running node!!.

Downloading Daedalus wallet from daedaluswallet.io and running the gui is equivalent to running full node? as my wallet is fully synced and i create a wallet using gui.


#14

Try reinstalling the node or find what you are doing wrong. There’s no problem in the node or in the API in general.


#15

daedalus wallet is node?


#16

Yes, it’s running a full-node as its backend. The GUI is only a front-end. When you’re using the API - you are talking with the node.

When you run Daedalus - full node get started automatically. Do you have Daedalus wallet open when you making the API calls?


#17

yes its fully synced and running, but unable to get response of api calls.


#18

Do you use windows? How are you making calls? Post here the commands you are running and the outputs.


#19

Daedalus is not using v1 API since it is not complete. But it currently supports all of the features needed for the exchanges. @zeshan_virk, the use case for the exchanges is probably similar to your use case so maybe this documentation would be of help for you:

Currently, there is no public testnet which you could use for the development of the integration. But there is “demo” mode available for the Cardano node which can be used for the development. It starts a local network with 4 nodes. You can follow readme from Daedalus repo to compile it and run it (./scripts/launch/demo-with-wallet-api.sh). There is also a key containing Ada for the demo network which can be imported as a wallet here https://github.com/input-output-hk/daedalus/blob/develop/features/support/default-wallet.key.


#20

You need to configure TLS certificates.