Importing Mnemonic wallet using cntools

Hi guys, I need some help importing a Mnemonic wallet in Cntools.

I have followed @Alexd1985’s guide to create a stake pool:

When I import a mnemonic wallet I get the error:

ERROR: need ‘bech32’ (command not found)
try ‘sudo apt install bech32’

*When I try *
sudo apt install bech32

I get the error:
E: unable to locate package bech32

I have tried to update and rebuild my cardano node

cd “HOME/tmp" curl -sS -o chmod 755 ./ . "{HOME}/.bashrc”

sudo systemctl stop cnode

cd ~/git
sudo rm -R cardano-node
git clone GitHub - input-output-hk/cardano-node: The core component that is used to participate in a Cardano decentralised blockchain.
cd cardano-node

git fetch --tags --all
git checkout 1.26.2

echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local
$CNODE_HOME/scripts/ -o

But when I look in the cabal/bin folder I cant find bech32 only these:


Hope someone can help me out

Thanks in advance

Can u check in /usr/local/… folder? Perhaps the files are there?

If not try to reinstall on another relay…

It doesnt show same error on the relay node, Anyway I can import the wallet to the relay and send it to the producer node ?

So, on ur relay is working to import?

Do u see the files in cabal folder?
If yes, try to copy the files (cardano-address and bech32) to the producer cabal folder

I’m having the same issue. I built two realy’s and one bp, however, none of them have the cardano-address or bech 32 folders). I have tried a few things such as:

  • Killing and trying on new server
  • Using older version (i.e. 1.26.1) branch
  • Looking at the code of the *.sh files to see if there is a parameter I can pass in

Unfortunately, I still cannot get the two folders. Thanks!

Did u built the node with -o option?

Yes, I did.

any updates on this, i’m also experiencing the same problem