Installing a Cardano node

Hi,
I’m trying to build and install a node according to the tutorial.
After the command cabal build all I’m supose to copy the executables files to the .local/bin directory with the command cp -p dist-newstyle/build/x86_64-linux/ghc-8.6.5/cardano-node-1.18.0/x/cardano-node/build/cardano-node/cardano-node ~/.local/bin/ which throws an error.
The problem is that there is no build directory in dist-newstyle.
I tried several git tags but I’m a bit lost. does anyone knows which executable files need to be copied to ~/.local.bin and where can I find them ?

Hello,

Can you please post the output of:

cardano-node --version

Thank you!

cardano : command not found
The node is not yet installed

well there you go

look at the output of cabal build all, as it appears something failed along the way

from there I will be able to help more

Looks like a dependency version problem :
Warning: Requested index-state2020-04-01T00:00:00Z is newer than ‘hackage.haskel.org’! Falling back to the older state (2020-03-31T22:47:49Z)
Resolving dependencies…
cabal: Could not resolve dependencies:```

try running the following:

cabal clean
cabal update
cabal build all

build to tag 1.18.0

cabal: unrecognised command clean
I have cabal version 3.2.0.0
This is getting all kinds of messed :slight_smile:

try running cabal update first and see if that works

and try to see if you can get a clue from the output as to the dependencies that failed from running cabal build all

Cabal cleaned, updated and rebuilt but the same problem persists. The path to the executable files is not valid since there are only 2 folders in cardano-node/dist-newstyle : cache and scr

I would need to see the output of the errors that occurred with cabal build all to further assist

You seem to have an issue with current version of Win32-network package (particularly the version of base within the package).

I’m not sure the process for upgrading the package on a Windows virtual machine, but that’s your issue

Most operators are running on a dedicated linux distribution so that’s where the majority of support will be available

Thank you, but the cazy part is that I have a Linux VM. I installed the newest version of Ubuntu on a virtual machine on my old Ubuntu system. No windows involved :).
Why would cabal try to build a Win32-network pakage on Linux?

Yeah that is odd - thanks for that info

Ok it looks like it might be the ghc compiler version you are running:

Check this thread:

1 Like

Thank you for the valuable reference. Problem fixed. Cardano-node installed and updated to version 1.18.0
The problem was indeed the ghc version. My previous installation was the more recent version ghc-8.10.2 which for some strange reason tries to build a win32-network dependency on debian 10 and fails. I was able to fix the problem by running the comand in the above reference than download and install the older ghc-8.6.5 on debian9

1 Like

hi, I’m getting that same error, but am using ghc-8.6.5. During the process, I have have hit the Enter key too soon (and carried on with pasting commands). I ended up with a Cardano-node directory inside the ghc-8.6.5 directory.
Is there a simple method of starting over?
I’ve set up a VM on Azure, running Ubuntu Linux 18.04.
New-ish with linux; been running Windows and Windows servers for work. Just starting in Linux. Thanks for any advice.

I’m not an expert either, I’m quite new to devellopement and IT. I can’t think of an easyer way than deleting the ghc folder and starting over. I also noticed that the ghc-9.6.5 has to be the one for debian 9.
However before you do that you could try to move the cardano-node directory outside the ghc.

I have the same problem. Actually, this will be the second time that I am passing through the process and the last time I didn’t have any problems. Seems that the the build, packagedb and the tmp folders from cardano-node/dist-newstyle/ are missing. Attached screenshot.

If the ghc-9.6.5 instalation worked without errors, you then need to copy the executables files to the .local/bin directory . The path of these file indicated in the couse is not accurate. The absolute path to these fiels is indicated in the last part of the output from the ghc instalation. You can also do a search to find the path to thsese file on your systhem. Once you have the paths for the node and cli executable files you can copy them to .local/bin directory .