Installing the stake pool node - No such file or directory


I am setting up a cardano stake pool on a Ubuntu 20.04 (LTS) x64 node and have run into a problem while installing it. Following the guide located at

When trying to copy the executables files to the .local/bin directory i get an error:


cp -p dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-node-1.21.1​/x/cardano-node/build/cardano-node/cardano-node ~/.local/bin/


cp: cannot stat ‘dist-newstyle/build/x86_64-linux/ghc-8.10.2/cardano-node-1.21.1​/x/cardano-node/build/cardano-node/cardano-node’: No such file or directory

I have tried running the installation as root and a normal user with sudo permissions. Getting the same error…

any tips?



Hello and welcome @madbear80,
the error message basically just says you are trying to copy something that does not exist. Please have a close look at the directories and version numbers.

Hi adatainment,
Thank you for the quick reply.

Im new to linux, but an experienced Powershell scripter on the MS platform.

I now ran:

-cabal update
-Trippelchecked my .bashrc, adding the missing
export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
-Did a source .bashrc
-New checkout tags/1.22.0

Then copied again, worked …