Installing the node from source - official documentation

I am following the following official documentation Installing the node from source.

section: " Building and installing the node"
After completing the cabal build all
I am having issues with:
cp -p "$(./scripts/ cardano-node)" ~/.local/bin/
cp -p "$(./scripts/ cardano-cli)" ~/.local/bin/

I am getting the following error:
-bash: ./scripts/ No such file or directory
cp: cannot stat '': No such file or directory

Please can someone advise?

Also, please can someone explain what is happening in “”$(./scripts/ cardano-node)"?. I am new to linux.

[I am using AWS Ubuntu 20.04 LTS, t3.large, and downloaded the
" Binary download for Ubuntu Linux 16.04 (x86-64, requires glibc 2.12 or later): cabal-install-"

The Haskell Cabal | Downloads


it is basically executing a command within a command.
So first it tries to execute ./scripts/ cardano-node and giving the output as a source for cp command.
could you try cabal install cardano-node cardano-cli

@laplasz I ran
cabal install cardano-node cardano-cli
And then:
cp -p "$(./scripts/ cardano-node)" ~/.local/bin/
cp -p "$(./scripts/ cardano-cli)" ~/.local/bin/

But I am still getting the error:
-bash: ./scripts/ No such file or directory
cp: cannot stat '': No such file or directory

but with cabal install the binaries should be copied to the ~/.local/bin folder - list the content of that folder and see what is there currently…

@laplasz , there is only one file inside ~/.local/bin:

1 Like

the scripts folder should be located under cardano-node git repository folder. in which folder have you executed the cp -p "$(./scripts/ cardano-node)" ~/.local/bin/
should executed inside the cardano-node folder

@laplasz I executed the script in the
~/src/cardano-node folder:

ubuntu@ip-172-31-8-117:~/src/cardano-node$ cp -p "$(./scripts/ cardano-node)" ~/.local/bin/

ok, so just list the scripts folder there ls scripts What is the output?

@laplasz ubuntu@ip-172-31-8-117:~/src/cardano-node/scripts$ ls -all:

hmm, the desired script is missing from the folder…
do you have the latest version checked out?

@laplasz I simply followed the official documentation:
git clone
git checkout tags/1.26.2

it is not there… only on branch master…
please checkout master branch: git checkout master

1 Like

@laplasz thanks man. you are a true Cardano Jedi master!

1 Like

:smiley: anyway, I will make an issue about this on github - good that you tried out the official doc

1 Like

thanks for this, solved my issue too.