Installing Cardano Relay Configuration (error: command not found)

I setup a cardano node following the guide on the below website, after not being able to get it to work using the guide on the Cardano website, however when I get to the part for Installing Cardano Relay Configuration, I paste the commands exactly as on the page and I am getting the error:
cardano-node: command not found

Any ideas what I’m doing wrong?

I tried again with the guide found on the Cardano website and I got the same error again, command not found.

Somewhere or other in the set of instructions you are using there is an install step. Make sure you are running that step. Also make sure that the place you are installing it is on your $PATH variable.

I searched the forum and found someone with a similar issue and it was basically that cardano-node --version was not recognizing, so I had to go back to the install instructions for that part and do it again and afterwards it worked. It wouldn’t work with my ip, so searched again on forum and saw multiple people having to switch the ip to all zeroes, I tried that and it extends and works.

Below is the part I had to re-enter and run and it fixed it. Ran with the following:

cardano-node run
–topology testnet-topology.json
–database-path db
–socket-path db/node.socket
–port 3001
–config testnet-config.json