IOHK statement: A Beta release for Daedalus on Linux


#42

daedalus (0.10#dev.1548) my daedalus shown these. am i correct on what I’m updating (latest update)?


#43

hey Jason, you are correct. I updated yesterday on OS X, that is what I see as well.


#44

Yes, latest update shows this. It’s ok.


#45

Got the following error message on RHEL 7.5 Workstation

unshare(): Invalid argument

Fixed it with

su -c "echo 10000 > /proc/sys/user/max_user_namespaces"

Might helpful for other RHEL editions or possibly CentOS.


#46

I’ve reinstalled Daedalus, hoping to have the new version, but it’s not the last version. How can I update Daedalus ?


#47

I installed it without problems on Ubuntu 18.04. I can’t import a wallet from my seed though. I entered the words and nothing happens.


#48

I installed Daedalus on Lubuntu 18.04 LTS. Not problem yet, but It’s still synchronizing … (although my internet connection is fast.)


#49

Updating,… all the sync process was fine. Without any problem. It seems very stable. During these days we will stress the wallet to see if failures arise with a couple of coins.


#50

Love that avatar!


#51

a quick hack to get more inodes is to create a loopback device with a fresh filesystem on it then mount it so that daedalus uses it to store your DB, this way you get a whole load more inodes from your diskspace that only consumes a few inodes on the underlying filesystem

You also get a super fast wipe of your daedalus installl by unlinking the loopback , if you need to do that in a hurry


#52

You do not need to mount any loopback dev, as you can use any new FS and mount it under the Daedalus’ DB dir. What, I did is I mounted an FS to some data dir (/data/Daedalus or similar) and just softlinked the Daedalus’ DB.

However, the issue is that a fresh installs on a laptop/PC use all disk space in which you cannot change inodes easily.


#53

Is anybody creating a snap or a flatpack?


#54

The reason for Linux binaries not being released is the million+ small files issue, which typically causes inode exhaustion on Linux filesystems (source). This problem will be solved with Cardano 1.4, which is coming in October. I think we can expect a release then.

Meanwhile, there is a community-made Linux guide that works with the current release.


#55

@mjackson001 posted on dev telegram:

Link: https://t.me/CardanoDevelopersOfficial/11003

Wanted to report back that I’ve been able to get Daedalus to run on Linux. there were some changes, most important of which was the settngs in /etc/nix/nix.conf have changed from previous source releases. I needed to update that file prior to running ‘nix build -f default.nix’. After that, the binary is in ./result/bin/daedalus. Unlike previous releases, you don’t need / want a separate Cardano SL node running locally, it’s bundled with the daedalus binary. Once I realized those issues, I am now up and running on Ubuntu from a source checkout of 0.11.0#1.3.0.dev.


#56

Hi,

I just want to report that version 0.11.1 (with node 1.3.1) compiles and works on CentOS 7. I have successfully sent and receive ADA between wallet and crypto exchange. Thanks!


#57

no plans that i am aware of to change our distribution format

we use nix for our linux releases and this does our package management agnostically of any linux distro


#58

Daedalus wallet installed in a Parrot OS 4.2.2 - Debian based (testing). fast synchronization. Pleasantly surprised.
endl


#59

Working on Qubes-os.org and FreeBSD (not as easy) too!