Monitoring delegated stake

I had executed the delegate-stake script and the output was the following.

counter: 2
- - a71bb29e6d4e0163c8f6ca8a26ddb885e82ae0a9b2cea0cb7d11c977dc05cd07
- 1
epoch: 0
reward: 0
value: 0

However, when i attempt to run the following jcli command
jcli rest v0 stake-pool get a71bb29e6d4e0163c8f6ca8a26ddb885e82ae0a9b2cea0cb7d11c977dc05cd07 --host “
the following error is returned.
failed to make a REST request
|-> node rejected request because of invalid parameters
|-> Client Error: 404 Not Found

Also, i am not able to see my stake pool on shelley explorer.

have you had enough ADA on your pledge-address when you ran the createStakepool script? you need at least 500+ ADA, otherwise the pooladdress is not getting registered on the chain. createStakepool doesn’t output an error if it didn’t work.

Yes I had around 510 ada. When I ran the script the amount reduced to just over 7 ada


have you used your secret_key when you called the

your id is not in the blockchain.

I ran the script again after i had transferred > 500 ADA to the address as i did not have enough the first time i ran the script.
When i checked the address before running the createStakePool, i could see the balance of the address on the shelley explorer with > 500.
That is when i re-ran the I could see my balance then reduced by 500 ADA.
I do remember though that when i ran the command to check my pool I could not see it. I then used the script.
After this i then uploaded my poolid.json and poolid.sig files to git.
Which were successfully committed.
So are you telling me now that i need to do this all over again and transfer another 500 ADA to the same address??
Can i get my original 500 ADA back then because i will just be doing the same steps as i did previously.

The json and sig files must be named with the PublicKey of the owner(you), not the poolid.

What is your PoolID?

The balance you see is your personal owner wallet balance, not the balance of the stakepool.
You can set the “delegate too” hash to any hash you randomly create, there must not be a pool with that hash. Wouldn’t make any sense to do this.

So the really important check is, to look that your poolid is in the blockchain after running the script. Also the github commit is just to see your Ticker listed within the Daedalus Wallet. But your pool is created in the time you ran the script.

Martin (ATADA)

My poolid is


The json and sig files i created were named with the public key - (contained in receiver_public.key)

your poolid is not in the blockchain, you can check it on

so, something went wrong with your “” command. :frowning:

Is there a definitive guide that i can step through then as i now will need another 500 ADA to start the process again.

Don’t know where the other 500 went.

Now wondering whether this staking is a wise investment. So many out there and having to try to compete with all these to be able to get some ADA…

here you can find a good one:

i did it with the description here:

but be careful, the parameter for the maxfee is no longer available on the latest!