My Relay node is starting

My relay node was working fine for over a month. Yesterday my Maschine seems to have restarted for no reason. Since then my relay keeps on status starting. Is there something I can do?

Screen Shot 2022-06-11 at 08.46.56

It is probably doing a check of the blockchain because it did not stop normally, you have to wait until this is complete. I takes about an hour normally. You can confirm this by watching the logs (journalctl -f -u cnode.service, assuming your service is called cnode).

1 Like

Try this

sometimes, when you stop/start/restart the node often you will hit this issue and you will need to perform the steps

  • stop the node
sudo systemctl stop cnode
  • rename ledger, immutable and volatile folders
ls -l
mv immutable imm
mv ledger led
mv volatile vol
ls -l
  • start/stop the node
sudo systemctl start cnode
stop the node after 10 sec
sudo systemctl stop cnode
  • you should also see now the new folders ledger, immutable and volatile
    delete the new folders created (not the old one renamed)
ls -l
rm -R ledger
rm -R immutable
rm -R volatile
ls -l
  • rename back the original folders
mv imm immutable
mv led ledger
mv vol volatile
ls -l
  • start the node and check glive (you should see now Mem RSS slowly increasing)
sudo systemctl start cnode
cd ..
cd scripts

Also check you have enough storage left. I had a similar issue when I was running out of storage on my harddrive.

1 Like

Thank you all, I did what @Alexd1985 has suggested and now its syncing.

Hi @Alexd1985 ,
I have the same issue but after I did these steps, It still stucking at β€œstarting”. This problem happen when I update the topology file from iohk relay to my relay IP, both mainnet & testnet with 1.35.0 version (followed your thread - clean installation on GCP instances). So, do I need to downgrade to 1.34.1? Thanks in advanced.

Cardano Node - (Relay - Mainnet) : 1.35.0 [9f1d7dc1] <
β”‚ Uptime: 00:11:58 β”‚ Port: 6000 β”‚ Guild LiveView v1.26.5 β”‚
β”‚ Epoch 0 [0.0%], 1d 15:10:24 remaining β”‚
β”‚ β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β––β–– β”‚
β”‚ β”‚
β”‚ Block : 0 Tip (ref) : 65263776 Forks : 0 β”‚
β”‚ Slot : 0 Status : starting Total Tx : 0 β”‚
β”‚ Slot epoch : 0 Density : 0.0 Pending Tx : 0/0K β”‚
β”‚- CONNECTIONS --------------------------------------------------------β”‚
β”‚ P2P : disabled Incoming : 0 Outgoing : 0 β”‚
β”‚- BLOCK PROPAGATION --------------------------------------------------β”‚
β”‚ Last Delay : 0.00s Served : 0 Late (>5s) : 0 β”‚
β”‚ Within 1s : 0.00% Within 3s : 0.00% Within 5s : 0.00% β”‚
β”‚- NODE RESOURCE USAGE ------------------------------------------------β”‚
β”‚ CPU node : 32.1% Mem (Live) : 3.3G GC Minor : 7480 β”‚
β”‚ Mem (RSS) : 8.4G Mem (Heap) : 8.3G GC Major : 20 β”‚
TG Announcement/Support channel: Telegram: Contact @guild_operators_official

[esc/q] Quit | [i] Info | [p] Peer Analysis

Nope, must be a FW issue if the nodes are working well with IOHK servers inside topology file

from BP try
telnet Relay_IP Relay_port
From Relay
telnet BP_IP BP_port

U should see connected… in case of not check the ufw rules

PS: the nodes must be 100% synced


Hi Alex,

Could you please help me with this error message?

node.service: Failed to reset devices.list: Operation not permitted

What operation? Check for all message

Hi @Alexd1985 ,

Both instances can’t reach to each other, ufw configed as instruction and running.
telnet result:

telnet: Unable to connect to remote host: Connection timed out
ufw status:
teko@core-node:/opt/cardano/cnode/scripts$ sudo ufw status
Status: active

To Action From

223/tcp ALLOW Anywhere
6000/tcp ALLOW Relay IP
223/tcp (v6) ALLOW Anywhere (v6)


I try with internal ip it’s connected. I’m so confused

teko@relay-node:/opt/cardano/cnode/scripts$ sudo ufw allow proto tcp from internal_ip to any port 6000
Rule added
teko@relay-node:/opt/cardano/cnode/scripts$ sudo ufw reload
Firewall reloaded
teko@relay-node:/opt/cardano/cnode/scripts$ sudo ufw status
Status: active

To Action From

223/tcp ALLOW Anywhere
6000/tcp ALLOW external_ip
6000/tcp ALLOW internal_ip
223/tcp (v6) ALLOW Anywhere (v6)

teko@relay-node:/opt/cardano/cnode/scripts$ telnet internal_ip 6000
Trying internal_ip…
Connected to internal_ip.
Escape character is β€˜^]’.
Connection closed by foreign host.
teko@relay-node:/opt/cardano/cnode/scripts$ telnet external_ip 6000
Trying external_ip…
telnet: Unable to connect to remote host: Connection timed out

I’ve solved my problem by add socket path to bashrc and restart the VMs. Now it’s working :slight_smile: , and it’s not about firewall. Thank you anyway Alex!

echo export CARDANO_NODE_SOCKET_PATH=β€œ$CNODE_HOME/db/socket” >> $HOME/.bashrc
source $HOME/.bashrc