No blocks for several epochs

My brother and I recently started our own pool. He’s the tech guy and I supplied the pledge. With 1.2mil in the pool, we minted 2 blocks in our first epoch and nothing in the last 2.5.

Is this normal for a new, low saturation pool? Everything appears to be online and functional. Just bad luck?

Yeah; last epoch I had 0 blocks assigned;

U can make 2-3 blocks one epoch and after 0

The averrage of the blocks/epoch matters!

Make ur pool known by community and u will attract more delegators;

Cheers,

2 Likes

Thank you for your reply. I am hopeful the average raises. As it stands, we have received only 50% of average. In 4 epochs, only 2 blocks. Expected result is 0.9 per epoch and we stand at 0.5

We tried to lower the pool before below the 340 minimum. Do you think this may have messed up our registration?

nope, 340 it’s the minimum and I think ur registration wasn’t successfully if u tried with a cost value bellow 340
Remember, it’s a lottery… 1 epoch u can have 0 blocks, another epoch 2-3… etc … the average on long term matters :wink:

Cheers,

5 epochs, 0 blocks. 1.2m in pool. Delegates are leaving now. This is not what I envisioned

Check the leaderlog … this way u will know if u had blocks assigned and missed

SOLVED
hello Alex:
I run the cncli.sh leaderlog and I always get this error, any ideas:
node@ny-producer:/opt/cardano/cnode/scripts$ ./cncli.sh leaderlog
~ CNCLI Leaderlog started ~
Node in sync, sleeping for 60s before running leaderlogs for current epoch
Running leaderlogs for epoch 256 and adding leader slots not already in DB
ERROR: failure in leaderlog while running:
/home/node/.cargo/bin/cncli leaderlog --db /opt/cardano/cnode/guild-db/cncli/cncli.db --byron-genesis /opt/cardano/cnode/files/byron-genesis.json --shelley-genesis /opt/cardano/cnode/files/genesis.json --ledger-set current --pool-id 5b6524492e17cf554c620fec9eda55278957bdf869da6da8525fc72e --pool-vrf-skey /opt/cardano/cnode/priv/pool/ADA_Pays_Stake_Pool --tz UTC
Error message: Is a directory (os error 21)
node@ny-producer:/opt/cardano/cnode/scripts$

Thanks for help
SOLVED

Hello,

Try

nano cncli.sh
for the

POOL_VRF_SKEY=

you need also the file name in the end

Thanks it worked

1 Like

this is my cncli.sh, any other parameter/variable that I might need for better operation?
######################################

User Variables - Change as desired

Common variables set in env file

######################################
POOL_ID=“5b6524492e17cf554c620fec9eda55278957bdf869da6da8525fc72e” # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation & pooltool sendtip, lower-case hex pool id
POOL_VRF_SKEY="/opt/cardano/cnode/priv/pool/ADA_Pays_Stake_Pool/vrf.skey" # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation, path to pool’s vrf.skey file
POOL_VRF_VKEY="/opt/cardano/cnode/priv/pool/ADA_Pays_Stake_Pool/vrf.vkey" # Automatically detected if POOL_NAME is set in env. Required for block validation, path to pool’s vrf.vkey file
#PT_API_KEY="" # POOLTOOL sendtip: set API key, e.g “a47811d3-0008-4ecd-9f3e-9c22bdb7c82d”
POOL_TICKER=“APAYS” # POOLTOOL sendtip: set the pools ticker, e.g “TCKR”
#PT_HOST=“127.0.0.1” # POOLTOOL sendtip: connect to a remote node, preferably block producer (default localhost)
#PT_PORT="{CNODE_PORT}" # POOLTOOL sendtip: port of node to connect to (default CNODE_PORT from env file) #CNCLI_DIR="{CNODE_HOME}/guild-db/cncli" # path to folder for cncli sqlite db
#SLEEP_RATE=60 # CNCLI leaderlog/validate: time to wait until next check (in seconds)
#CONFIRM_SLOT_CNT=600 # CNCLI validate: require at least these many slots to have passed before validating
#CONFIRM_BLOCK_CNT=15 # CNCLI validate: require at least these many blocks on top of minted before validating
#BATCH_AUTO_UPDATE=N # Set to Y to automatically update the script if a new version is available without user interaction
#LEDGER_API=true # Use API from api.crypto2099.io in cncli call instead of local ledger-state dump to vastly reduce system resources. ONLY for MainNet network (true|false)

Nope (looks fine)… did u checked also for 257?
Any luck?

you mean cncli.sh leaderlog?
It checked but no luck :disappointed_relieved:

what is that value, for metric? “metric”:-353.73785161306,"

What metric is this?

Thanks for your feedback Alex. cncli showed no missed blocks. 2 blocks in epoch 250, then 5 epochs with 0. It shows 2 scheduled next epoch.

1 Like

Mightydeno, with your two scheduled blocks, did you get them the following epoch? Was just curious

No. We missed them entirely. We upgraded the RAM on our node and began successfully minting.

Whats specs are you running,

My relay node is 4gb and 2cpu

And my BP is 8gb and 2cpu

Relay node I see suffers a little but BP is now running smooth

If u want u can go (on Relays) inside the config file and set the TraceMempool=false
Then restart the nodes

The MEM used will decreased but u will not see processed TX anymore on relays… u will see only on BP

1 Like