Please help with checking my Stakepool configuration

Hi everybody - I really could do with some help from the community on this forum as I really do not know if there is a configuration issue with my Block Producing Node or not. I was regularly minting blocks on my Stakepool for 18 months and then moved my node to the cloud. Since moving it I have not been allocated one block in the last 21 Epochs. Now I know that with an average stake during this period of 300k that blocks are infrequent but the odds of not being allocated one in this time is getting extremely low and I am starting to think that I may have done something wrong. Any advice or help would be very much appreciated

Just as a guide I have provided the following information

  • Node is showing as Core in gLiveView
  • Tip is increasing as it should
  • KES keys are current with 38 days remaining
  • Both relays can be seen from Block Producing Node
  • Both relays can see the BP Node
  • Node is 100% synced
  • Chrony is active and running
  • vrf key hash matches what is showing on Pooltool
  • Pool is showing as active on Pooltool and all other websites
  • All relevant keys and certificates are in the correct location
  • I have latest version of cntools and checked blocks on there and have also manually run the cncli leaderlog check. I have run ./cncli.sh init and can see all blocks allocated up until Epoch 320

Given the above information is there anything else I can check to be sure that the Pool is registered correctly on the network to be eligible for slot leadership? It is getting pretty desperate now because if this is not down to just bad luck I really have to sort it out urgently and I want to be sure that I am doing everything possible for my delegators.

Many thanks in Advance

GNP1

1 Like

Do you run leaderlogs to know for which slots you’re elected slot leader?

1 Like

Yes - I have done it manually with ./cncli.sh leaderlog and it just says leaderlogs calculated for the relevant Epoch and with 0 blocks - I understand the latest cntools does this automatically as well - I have checked cntools for blocks and it shows zero for every Epoch since 320

If leaderlogs show zero slots, you aren’t assigned any slots and it’s normal that you haven’t minted any blocks. With your stake chances of no slots elected for 20 epochs in a row are about 1% I think. This is very low, but not impossible…

1 Like

Thanks - yes I am hoping it is just a run of poor luck on the leaderslot allocation but the longer it goes the more it makes me wonder if something is set up wrong. As this only happened after moving my node there is no way to be sure until I get allocated a block :slight_smile:

Anyway really appreciate your help and if anyone has any other ideas that would be great

If you have node 1.34.1 you can run leaderlogs with the node itself and compare (you’ll need a lot of memory though, or it’ll crash).

Thanks - how do I do that other than run the command ./cncli.sh leaderlog

> cardano-cli query leadership-schedule \
   --testnet-magic 42 \
   --genesis example/shelley/genesis.json \
   --stake-pool-id  pool12t0y7agkqct89pf00eeytkvfjlquv76tjy27duannan9w63ckxv \
   --vrf-signing-key-file example/node-pool1/shelley/vrf.skey
   --current

   SlotNo                          UTC Time
   --------------------------------------------------------
   4073                   2021-12-29 17:26:54.998001755 UTC
   4126                   2021-12-29 17:27:00.298001755 UTC
   4206                   2021-12-29 17:27:08.298001755 UTC
   4256                   2021-12-29 17:27:13.298001755 UTC
   4309                   2021-12-29 17:27:18.598001755 UTC
   4376                   2021-12-29 17:27:25.298001755 UTC
   4423                   2021-12-29 17:27:29.998001755 UTC
   4433                   2021-12-29 17:27:30.998001755 UTC

This is for current epoch and testnet.

2 Likes

Thanks - I will have a look at this

I ran the leaderlogs as you suggested and got the same result - no blocks - thanks for the suggestion

And again another Epoch has passed with no blocks assigned - at what point does this no longer become bad luck and there is an issue with something?

Do you have to rotate the kes key? Are you sure to update the key on the new server

Yes the keys were rotated just recently and I have 35 days remaining - besides that would only have an effect on minting the block and not being selected as a slot leader wouldn’t it?

Is there anyone from IOG or any developers that I can speak to or anyone who considers themselves a true expert in running a Stakepool. I can see nothing wrong with the configuration of my Stakepool but yet no allocations for 22 Epochs just does not seem right. Apart from asking for help on this forum I am not sure who else we can turn to - any ideas? anyone?

Does the Ourabouros protocol allow this to happen? The odds now for this happening are becoming extremely low based on my calculations - how can I know for sure?

The stake pool operator group on Telegram is quite active: https://t.me/CardanoStakePoolWorkgroup

1 Like

Thanks - I will take a look

Make sure that you updated the new key on BP when you rotated them, check the certificate and OpCertC number, for example

1 Like

The op.cert, hot.skey, hot.vkey and kes.start and cold.counter all were updated on the day the keys were rotated - that should be ok - yes?

what is the current OpCertC No, is it 8 or other?

if I run this

cardano-cli text-view decode-cbor --in-file op.cert | grep int | head -1
09 # int(9)

Is this what you mean? if so I get 9