Only one unreachable IN connection and no increase in TX?

Evening Cardanoans,

Me and some mates have been struggling a couple of days trying to get a pool up and running
on the testnet, using this guide:
The guide is written for the mainnet, however we figured that we would try to use it for the testnet, before jumping the mainnet. Unfortunately we’ve run into couple of troubles.

#1 Only one inbound connection, which is unreachable on the relay
#2 No increase in TX

We’ve used the topologyUpdater on the Relay and reached the state of the API responding with “glad you’re staying with us”

The only thing we’ve changed is in the and that is to use the testnet instead of the mainnet.

curl -s -o /home/ubuntu/cardano-my-node/testnet-topology.json "${BLOCKPRODUCING_IP}:${BLOCKPRODUCING_PORT}:2|"

Our Testnet-topology.json looks like this:

{ "resultcode": "402", "datetime":"2021-02-11 15:04:47", "clientIp": "--relayIP--", "iptype": 4, "msg": "IP is not (yet) allowed to fetch this list",  "Producers": [   { "addr": "--BP IP--", "port": 6000, "valency": 2 }, { "addr": "", "port": 3001, "valency": 2 },
 { "addr": "", "port": 3001, "valency": 2 } ]  }


      "ApplicationName": "cardano-sl",
      "ApplicationVersion": 0,
      "ByronGenesisFile": "testnet-byron-genesis.json",
      "ByronGenesisHash": "96fceff972c2c06bd3bb5243c39215333be6d56aaf4823073dca31afe5038471",
      "LastKnownBlockVersion-Alt": 0,
      "LastKnownBlockVersion-Major": 3,
      "LastKnownBlockVersion-Minor": 0,
      "MaxKnownMajorProtocolVersion": 2,
      "Protocol": "Cardano",
      "RequiresNetworkMagic": "RequiresMagic",
      "ShelleyGenesisFile": "testnet-shelley-genesis.json",
      "ShelleyGenesisHash": "849a1764f152e1b09c89c0dfdbcbdd38d711d1fec2db5dfa0f87cf2737a0eaf4",
      "TraceBlockFetchClient": true,
      "TraceBlockFetchDecisions": true,
      "TraceBlockFetchProtocol": true,
      "TraceBlockFetchProtocolSerialised": true,
      "TraceBlockFetchServer": true,
      "TraceChainDb": true,
      "TraceChainSyncBlockServer": true,
      "TraceChainSyncClient": true,
      "TraceChainSyncHeaderServer": true,
      "TraceChainSyncProtocol": true,
      "TraceDNSResolver": true,
      "TraceDNSSubscription": true,
      "TraceErrorPolicy": true,
      "TraceForge": true,
      "TraceHandshake": true,
      "TraceIpSubscription": true,
      "TraceLocalChainSyncProtocol": false,
      "TraceLocalErrorPolicy": true,
      "TraceLocalHandshake": false,
      "TraceLocalTxSubmissionProtocol": true,
      "TraceLocalTxSubmissionServer": true,
      "TraceMempool": true,
      "TraceMux": false,
      "TraceTxInbound": true,
      "TraceTxOutbound": true,
      "TraceTxSubmissionProtocol": true,
      "TracingVerbosity": "NormalVerbosity",
      "TurnOnLogMetrics": true,
      "TurnOnLogging": true,
      "defaultBackends": [
      "defaultScribes": [
      "hasEKG": 12788,
      "hasPrometheus": [
      "minSeverity": "Info",
      "options": {
        "mapBackends": {
          "cardano.node.metrics": [
          "cardano.node.resources": [
        "mapSubtrace": {
          "cardano.node.metrics": {
            "subtrace": "Neutral"
      "rotation": {
        "rpKeepFilesNum": 10,
        "rpLogLimitBytes": 5000000,
        "rpMaxAgeHours": 24
      "setupBackends": [
      "setupScribes": [
          "scFormat": "ScText",
          "scKind": "StdoutSK",
          "scName": "stdout",
          "scRotation": null

We are not able to find our relay here:

Any idea what our problem could be? Don’t hesitate to ask for further informations. Much appreciated!

1 Like

Hi, I think your testnet-topology.json on realy should look like this

“Producers”: [
“addr”: “”,
“port”: 3001,
“valency”: 2
“addr”: “your block producer IP”,
“port”: xxxx,
“valency”: 1

The reason why our Testnet-topology.json looks like above is because the updates it

Have you tried to add some relays from this list above?

{ “resultcode”: “402”, “datetime”:“2021-02-11 15:04:47”, “clientIp”: “–relayIP–”, “iptype”: 4, “Producers”: [
{ “addr”: “–BP IP–”, “port”: 6000, “valency”: 2 },
{ “addr”: “”, “port”: 3001, “valency”: 2 },
{ “addr”: “”, “port”: 3001, “valency”: 2 },
{ “addr”: “”, “port”: 3001, “valency”: 2 }
] }

I managed to get it to work, just had to add magic to the Testnet-query in the It is now processing blocks and such.

However, I don’t see the pool in the Daedalus Testnet wallet?

Did you modify metadata?

Yes we have modified the metadata for the pool for our pool. We have ensured that hash for the metadata file and the url metadata matches

You need to do step “8.3 Generate Stake pool registration certificate” again.

We’re now trying to get it to work on the mainnet, we’re processing a lot of TX, but both our relays are marked af unreachable in IN on our BP? Any ideas why?

Press P to find why

How would that tell me why? The relays are reachable from OUT on the BP, but not in, even thought its the exact same IPs.

Press P (in glive) to find why

That is what I’m doing. Both the relays are reachable OUT, but not IN.

Ooo sorry, press i (sorry again)

So I should disable ICMP in the firewall?

Why? Are working fine, right?

I should try these out? It was the last sentence that made my think of disable ICMP, if enabled.


Ooo, yes , I blocked icmp for my nodes
But if ur nodes are on the same network… just block the icmp from the outside…

You mean disabled, right?

I use to say enable icmp filtering - for u is disable icmp