No inbound peers


I just setup my first pool, and I don’t seems to have any connections inbound (my relay IP can be found on )

The relay port is open, and the BP is connected to the relay, so I’m not sure what exactly it is that I am doing wrong.

Perhaps someone could help?



What is your ticker/


Hello Alex,

My ticker is BBFSH


TY, on your relay are u running topologyupdater script to announce your node into the network?
If yes can u check the last message from topologyupdater log?
also can you tell me your relay IP + port registered?

Thanks once again,

Yes I am running the topologyupdater script, last update was about 30 mins ago:

{ “resultcode”: “204”, “datetime”:“2021-02-08 08:58:01”, “clientIp”: “”, “iptype”: 4, “msg”: “glad you’re staying with us” }

The port is 6000.


ok, and how did u start the node, can u show me the script?

Here it is:

cardano-node run --topology ${TOPOLOGY} --database-path ${DB_PATH} --socket-path ${SOCKET_PATH} --host-addr ${HOSTADDR} --port ${PORT} --config ${CONFIG}

something wrong with your hash

[{“time”:“08.02.2021. 03:41:11”,“retryCount”:1,“poolHash”:“569ae22bbbc346efc0ca4293126a5660aa92606d43ff7d249fddff4123e83e8a”,“cause”:“Hash mismatch from poolId ‘5db8a93c814f29fa4dfc9f60038b1cfbaac345eb51366a8072a9e3e6’ when fetching metadata from ‘’. Expected 569ae22bbbc346efc0ca4293126a5660aa92606d43ff7d249fddff4123e83e8a but got fdd334a4f99ce0e23ccce3032bd46e687a000563e6c8dbdcc5e2b5c3be1fb6ee.”,“poolId”:“5db8a93c814f29fa4dfc9f60038b1cfbaac345eb51366a8072a9e3e6”,“utcTime”:“1612755671.287468s”},

but I can’t see your metadata at that link provided… it’s saying err 404
404: Not Found

This was an erroneous metadata file at that link (some extra characters that I accidentally pasted), I have since resubmitted a transaction with the correct json file, which has been picked up pooltool:

Metadata last checked: February 8th 2021, 6:48:38 am
Hash: cd3ea8cc5d5a1f0ffd7a589536c6e91d9f627314a55f78c135d6a58bfe96d70c
metadata pool description: An EU-based pool
metadata pool homepage:
metadata pool name: Babelfish Pool

The new file is on, and the pool appears OK on Daedalus too (but not on adapools, not sure why).
Should I just wait in case info is updated?

Thanks once again :slight_smile:

yes but youshould see transactions…

add my relay at custom peers + topology file and restart the node I will add on mine node too. after that u should see transactions. I added ur Relay


ok, and wait more days , your peer in connections should increase

Thanks Alex, sorry for the late reply but newborn baby > stake pool :slight_smile:
I don’t know if this is what did the trick, but I’m seeing inbound connections now:
2021-02-08 (1)

great, in time you should see more… active nodes which already running needs to be restarterd by the operators in order to connect yours. and also you need to restart your node at least once/24 hours to refresh your topology… (If u seted as systemd I think there is already seted to restart at each 24 hours)

PS: congrats for the new member of fam!

and delete your last screenshot, your BP ip is visible :stuck_out_tongue: stay safe

Hi @Alexd1985 ,
On Testnet, My Stake Pool (1 BP + 1 Relay) was working fine and even generated Blocks in last 2 Epoch. However now I am trying to add a second Relay to the mix but there seems some anomaly.

  1. BP is showing both Relays in its outbound peers.
    │ 1 1 Bengaluru, IN │
    │ 2 264 Nuremberg, DE

  2. BP is showing only First Relay in its inbound peers.
    1 1 Bengaluru, IN

  3. 2nd New Relay is showing 14 outbound peers (only 6 pasted here for sample).
    1 17 Frankfurt am Main, DE │
    │ 2 29 Nuremberg, DE │
    │ 3 53 Amsterdam, NL │
    │ 4 58 Düsseldorf, DE │
    │ 5 60 Amsterdam, NL │
    │ 6 65 Helsinki, FI

  4. 2nd New Relay is showing 2 inbound peers, one of which is BP. 2nd inbound peer is undetermined and showing blank RTT value.

    1 BP-IP:BP-PORT 135 Bengaluru, IN │
    │ 2 — Santa Clara, US

w.r.t. 2nd point above, just one Relay is not normal. It must show both the Relays there, correct ?
w.r.t. 4th point above, there must be more than 2 inbound peers on the new Relay, correct ? (the First Rely shows so many inbound peers).

topology.json on New Relay is looking good and reflecting the BP in below format :

“addr”: “BP-IP”,
“port”: BP-Port,
“valency”: 1

just tried to telnet from BP to Relays and vice versa

  1. BP is successful in reaching both the Relays with specific Ports
  2. Old Relay is successful in reaching the BP with specific Port
  3. New Relay is failing in reaching the BP with specific Port
  4. Old Relay is successful in reaching the New Relay with specific Port
  5. New Relay is successful in reaching the Old Relay with specific Port

Did u checked the ufw ? U must allow on BP the new Relay IP

Thanks Alex, it got solved. BP’s ufw firewall was in-fact missing the rule to allow inbound connection from New Relay’s IP to its port.

1 Like