Relay not listed in topology.json

Hello,
I spent last few days setting up my pool.
It seems to be almost done, but on my relay node, i have 0 in connections.
Ive noticed, that my relay is not in this list: https://explorer.mainnet.cardano.org/relays/topology.json

I went through this manual Relay node setup completed but Processed TX : 0 (no transactions processed) and everything seems ok.

Do you have any other tips, please?

Thank you,
Matt

Hello,

Yes; are u using topologyupdater script?

yes please

i just forwarded port 3001 to my relay and stuff started to happen. processed TX started to move aswell as mempool changed. still none incomming tho

my relay is on port 6001 and producer 6000, both running on same W10Pro machine in hyper v on ubuntu server 20

Check the port in fw, is it opened?
What is the last message from topologyupdater script?

fw is disabled in linux. message from script is ok, i even checked the errors by pool id and metadata hash according to your post mentioned above. i checked my ports 6000/6001 at https://www.portcheckers.com/

Do u use cntools? Can u show me the output from gliveview from ur relay?

what is the ressultS?
are the ports open and available?

i dont use cntools i think.

ports are ok

On relay in topology updater to custom peer option, did u added your BP and port?

Can u paste your config file here?

Then… show me the last topologyupdater log message

#!/bin/bash

shellcheck disable=SC2086,SC2034

USERNAME=xxx
CNODE_PORT=6001 # must match your relay node port as set in the startup command
CNODE_HOSTNAME=“CHANGE ME” # optional. must resolve to the IP you are requesting from
CNODE_BIN="/usr/local/bin"
CNODE_HOME=/home/xxx/cardano-my-node
CNODE_LOG_DIR="{CNODE_HOME}/logs" GENESIS_JSON="{CNODE_HOME}/mainnet-shelley-genesis.json"
NETWORKID=$(jq -r .networkId GENESIS_JSON) CNODE_VALENCY=1 # optional for multi-IP hostnames NWMAGIC=(jq -r .networkMagic < GENESIS_JSON) [[ "{NETWORKID}" = “Mainnet” ]] && HASH_IDENTIFIER="–mainnet" || HASH_IDENTIFIER="–testnet-magic {NWMAGIC}" [[ "{NWMAGIC}" = “764824073” ]] && NETWORK_IDENTIFIER="–mainnet" || NETWORK_IDENTIFIER="–testnet-magic ${NWMAGIC}"

export PATH="{CNODE_BIN}:{PATH}"
export CARDANO_NODE_SOCKET_PATH="${CNODE_HOME}/db/socket"

blockNo=(/usr/local/bin/cardano-cli query tip {NETWORK_IDENTIFIER} | jq -r .blockNo )

Note:

if you run your node in IPv4/IPv6 dual stack network configuration and want announced the

IPv4 address only please add the -4 parameter to the curl command below (curl -4 -s …)

if [ “{CNODE_HOSTNAME}" != "CHANGE ME" ]; then T_HOSTNAME="&hostname={CNODE_HOSTNAME}”
else
T_HOSTNAME=’’
fi

if [ ! -d {CNODE_LOG_DIR} ]; then mkdir -p {CNODE_LOG_DIR};
fi

curl -4 -s “https://api.clio.one/htopology/v1/?port={CNODE_PORT}&blockNo={blockNo}&valency={CNODE_VALENCY}&magic={NWMAGIC}${T_HOSTNAME}” | tee -a $CNODE_LOG_DIR/topologyUpdater_lastresult.json

that is from coincashew guide.
last message was 204, glad you are here

just checked topology.json again and im there now :slight_smile:

What is ur ticker?

it is M1CZ, i can see it in daedalus

Ok, on BP in topology file what IP did u configured for your relay?

local address of relay - 192.168.0.101, port 6001

Dis u also opened a portforward for your relay? 6001?