Relay node tolology.json peers

I have a new pool up and running and registered mostly using the CoinCashew guide. In my topology.json on my relay node, I have my producer node and the relays-new . iohk one.
I have published my relay node and I can see it here:
When trying to run in the CoinCashew guide, I keep getting “IP is not (yet) allowed to fetch this list”
It’s been several days. A couple questions:
Should my topology.json have all the relays in the above URL? I tried adding one or two manually, but my node doesn’t start with them in there. gLiveView just says starting…
Is there something else I need to do to be allowed to fetch the list? Is it because I registered with my domain name and not my ip?

I managed to add some peers manually. I believe the mistake I was making was to add the snippet of json for peers as it appears in
I tried taking out continent and state and adding a valency value and my node starts up now and gLiveView shows
out / in
peers: 8 3
What’s an adequate number of peers to add?
My previous question still stands. If someone can help me get working, I’d be very grateful!

Salut Pierre,

What is your ticker ?

Did you set cronjob ?

You should have max 20 peers.

Tu peux m’écrire en privé besoin :slight_smile:


1 Like

I did setup as a cron job, but I had never checked the log for result. Just checked it now and it is always returning
502 "invalid blockNo
It works fine and returns "“nice to meet you” if I run it outside of cron. Must be something missing in the environment when running through cron. I think I know. Tried something. We’ll see in a couple hours…

So when I get the topology pull working, it should return a random list of less than 20 peers in my topology.json, should it?


That worked! I now get “welcome to the topology” in the log and I was able to update my topology and got 20 peers.


is there a way to manually publish my relay topology to the network so others can connect to me? I am having trouble getting the working.