Realy node not present in topology file

Hello all,
on testnet I’m running a pool composited by one producer node and one relay node.
These are the producer peers statistics:

immagine

These are the relay peer statistics:

immagine

As you can see I have only 1 “peer In” ( my producer ) and my relay is not present on https://explorer.cardano-testnet.iohkdev.io/relays/topology.json

the last 3 events from topologyupdater.sh are:

{ “resultcode”: “201”, “datetime”:“2021-10-12 10:33:10”, “clientIp”: “93.42.90.87”, “iptype”: 4, “msg”: “nice to meet you” }
{ “resultcode”: “201”, “datetime”:“2021-10-12 11:33:11”, “clientIp”: “93.42.90.87”, “iptype”: 4, “msg”: “nice to meet you” }
{ “resultcode”: “201”, “datetime”:“2021-10-12 12:33:05”, “clientIp”: “93.42.90.87”, “iptype”: 4, “msg”: “nice to meet you” }

The public ip/port is working as expected. Did I fail something?
Can you help me to locate the issue?

Thank you all

For both topology-updater scripts (pull and push), please make sure to include the magic query parameter for the testnet:

Example:
ie https://api.clio.one/htopology/v1/?port=...&magic=1097911063

If you are already including this let us know or paste the scripts so we can take a look.

Hello and thank you for your reply!
I don’t know what happened but now I have 2 more “Peers in”:

immagine

But my relay is still not present in https://explorer.cardano-testnet.iohkdev.io/relays/topology.json

Those are the scripts:
topologyUpdater.sh

###
### On relaynode1
###
#!/bin/bash
# shellcheck disable=SC2086,SC2034

USERNAME=alessio
CNODE_PORT=6000 # must match your relay node port as set in the startup command
CNODE_HOSTNAME="CHANGE ME"  # optional. must resolve to the IP you are requesting from
CNODE_BIN="/usr/local/bin"
CNODE_HOME="/home/alessio/cardano-my-node"
CNODE_LOG_DIR="${CNODE_HOME}/logs"
GENESIS_JSON="${CNODE_HOME}/testnet-shelley-genesis.json"
NETWORKID=$(jq -r .networkId $GENESIS_JSON)
CNODE_VALENCY=1   # optional for multi-IP hostnames
NWMAGIC=$(jq -r .networkMagic < $GENESIS_JSON)
[[ "${NETWORKID}" = "Mainnet" ]] && HASH_IDENTIFIER="--mainnet" || HASH_IDENTIFIER="--testnet-magic ${NWMAGIC}"
[[ "${NWMAGIC}" = "764824073" ]] && NETWORK_IDENTIFIER="--mainnet" || NETWORK_IDENTIFIER="--testnet-magic ${NWMAGIC}"


export PATH="${CNODE_BIN}:${PATH}"
export CARDANO_NODE_SOCKET_PATH="${CNODE_HOME}/db/node.socket"

blockNo=$(/usr/local/bin/cardano-cli query tip --testnet-magic 1097911063 | /usr/bin/jq -r .block )

# Note:
# if you run your node in IPv4/IPv6 dual stack network configuration and want announced the
# IPv4 address only please add the -4 parameter to the curl command below  (curl -4 -s ...)
if [ "${CNODE_HOSTNAME}" != "CHANGE ME" ]; then
  T_HOSTNAME="&hostname=${CNODE_HOSTNAME}"
else
  T_HOSTNAME=''
fi

if [ ! -d ${CNODE_LOG_DIR} ]; then
  mkdir -p ${CNODE_LOG_DIR};
fi

/usr/bin/curl -4 -s "https://api.clio.one/htopology/v1/?port=${CNODE_PORT}&blockNo=${blockNo}&valency=${CNODE_VALENCY}&magic=${NWMAGIC}${T_HOSTNAME}" | /usr/bin/tee -a $CNODE_LOG_DIR/topologyUpdater_lastresult.json

relay-topology_pull.sh

#!/bin/bash
BLOCKPRODUCING_IP=192.168.1.160
BLOCKPRODUCING_PORT=6000
curl -4 -s -o /home/alessio/cardano-my-node/testnet-topology.json "https://api.clio.one/htopology/v1/fetch/?max=20&magic=1097911063&customPeers=${BLOCKPRODUCING_IP}:${BLOCKPRODUCING_PORT}:1|relays-new.cardano-testnet.iohkdev.io:3001:2"

Let me know please if you something wrong
Thank you again
Regards

It needs some time after other pools update their topology and get your relay address. On testnet maybe even longer than on mainnet.

I’m not sure how often https://explorer.cardano-testnet.iohkdev.io/relays/topology.json refresh their cache.

Please also check on: