topologyUpdater, IP is not (yet) allowed to fetch this list

topologyUpdater has been running fine on relay node1 (testnet). Today, finally spun up second testnet relay node. Installed cntools and tried running topologyUpdater.sh after updating the env and topologyUpdater.sh user details on the new relay node. Getting this error on relay 2 in the resulting topology file

“resultcode”: “402”,
“datetime”: “2021-05-24 03:10:53”,
“clientIp”: “xxx.xxx.xxx.xxx”,
“iptype”: 4,
“msg”: “IP is not (yet) allowed to fetch this list”,
“Producers”: [
{
“addr”: “relays-new.cardano-testnet.iohkdev.io”,
“port”: 3001,
“valency”: 2
},
{
“addr”: “ip address of block producer node”,
“port”: xxx,
“valency”: 1
}
]
}

Also, seeing this in the updater log I’m writing to fro
{ “resultcode”: “503”, “datetime”:“2021-05-24 03:10:53”, “clientIp”: “xxx.xxx.xxx.xxx”, “msg”: “blockNo 544599 seems out of sync. please retry” }m the script

I’ve checked different websites about the updater, and did see one forum post about the “IP is not (yet) allowed to fetch this list”, but that didn’t help. Querying the tip on relay 2 doesn’t help (saw something on cardanoupdates about querying the tip before being able to make a valid request to the topology repository.

Has anyone seen this error before, and what was your resolution? Thanks in advance!

First, the node is synced? Then, the producer is accepting connections from relay? Check the port in fw;

Cheers,

From the error it looks likeyour node is not fully synced. Sync and try again

Yep, had to be synced. I checked the next day and relay was matching slots with the producer node, then the updater worked.

When you say sync the node, are you referring to some cardano-cli command that would synch it, or syncing just means waiting for the relay node to catch up, like I did?

Thanks for the assist!