Poolmeta.json Issue

Hello -
Hoping someone can help me out… I just deployed a new pool (TYGAR) but it’s not appearing in any wallets. After doing some research, I ran:

curl “https://smash.cardano-mainnet.iohk.io/api/v1/errors/[POOL ID]”

And am seeing there’s a mismatch in the hash of my poolmeta.json file but I don’t know why, or how to fix it. I’ve tried to update the pool data a few times and replace the file, but the same mismatch keeps appearing.

Any thoughts?


Where are u hosting the file?



I just verified and your pool looks ok in adapools.org and pooltool… but indeed there is no tygar pool in yoroi… but u have other issue…

  • Ur nodes are fully synced?
  • On ur relay are u using topology updater, if yes what is the last message received in topology updater log file
  • your Producer is running as a Producer or as a relay
  • check ur relays port seems to be closed

Port 3001 is closed on
Port 3001 is closed on


1 Like

Ah, very good catch. Thank you. I believe I have that fixed now (it might still be refreshing).

1 Like

Ok, but u have IN peers right? Other people added ur relays manually in their topology file right?

Now… regarding the ports, perhaps u have some fw in cloud… u should check

Like many others, I constantly run into trouble when updating pool meta data. It always disappears from Daedalus however within minutes the correct data appears on other sites such pooltool, adapools, yoroi, etc. which validate file hashes tellign me the data is correct.

Also, I use both the Windows and Linux versions of the most recent wallet. Even worse, today after re-delegating some ADA using the Windows wallet to move to a different pool, looking at my delegation in the Linux wallet has not changed to the new delegation. It still shows as delegated to the old pool. There must be some caching issues or major delays in the SMASH server re-checking pool meta data to verify hash signatures and then update the Daedalus wallet - or maybe the problem lies somewhere within the Daedalus wallet architecture itself. Frustrating.

@Alexd1985 - Thank you very much for your help and all of your contributions to this forum and community. I think I’m all set now and everything is looking correct. Appreciate it!

1 Like

You are welcome!

1 Like

Hi @mcvetyty

I’m currently running into the exact same issue you went thought.

My pool doesn’t show the ticker on pooltool.io whereas I can somehow see it on adapool.

The metadata seem correct to me and have been published.
I noticed though that you have “nonce” set on yours (needed?)

Any thoughts? Thanks a lot.

The errors I’m getting are the same than the ones you were getting.


Hey there! I can certainly try to help… What I actually learned about that error, at least for me, is that the I wasn’t noticing the timestamp of the message. If I recall correctly, everytime you run the command it just shows you the last few messages but that doesn’t mean they’re still issues. Is the timestamp current or outdated on yours?

When did you create the pool? For me, it just took a few hours and then eventually appeared on Daedalus.

I don’t know if I wrong, if YES someone correct me, but shouldn’t be https protocol?
I saw your site doesn’t have a ssl certificate…
try to upload your metadata on gitthub
8. Register a Stake Pool with Metadata — cardano-node Documentation 1.0.0 documentation (chapter 8)

I think it’s definitely recommended, but not required. I am seeing other pools (TIKI for example) that use HTTP and appear to be working.

yes, but u are sure TIKI has the metadata uploaded to tiki domain, perhaps it is in github

Ah, good point. That could be!


First, see if the timestamp is current, second perhaps try to get an SSL cert on your site and make the update. Third, are you using CNTOOLs or manually creating your pool? In CNTOOLs there is an option to pull the metafile data down from your website instead of having it generated for you to push it up - perhaps try that so you know the hashes should snyc?

he can try to upload the metadata to github,

I observed two challenges after registering my pool yesterday:

  1. I could not find my ticker on pooltool.io. However while registering my pool i used the default url (https://foo.bat/poolmeta.json) because I do not have a personal url.
  2. when i try pool >> show from ./cntools.sh. I get the **ERROR: ledger dump failed/timed out increase timeout value in cntools.config. (After this action i notice my production pool node restarts when i check status (sudo systemctl status cnode.service).
    Please kindly assist.
  1. if you don’t have a personal URL then u can upload the metadata on github and use that URL (check my topic… how to do that)
  2. nano cntools.sh and try to increase the timeout value to 500 and activate by deleting the # from the begining.


Hi Alexd1985.
the error suggest increasing timeout value in cntools.config. (Corect me if i am wrong). I have tried locating the line on cntools.sh but dont seam to identify where to make the change. However the cntools,config seam to have the 600 value already.
Please correct me if i am not doing something right.
2. Can you help me with the link to your topic on uploading the metadata on github,