Resolving metadata.json url error?

Thank you very much for your time. My apologies if this has been a topic thats been already addressed. I created two relay and a bp nodes and registered my pool. But when I provided the metadata link, I provided file without .json. I was not sure if this can be an issue. I was not able to get a hash when I ran below command.
cardano-cli stake-pool metadata-hash --pool-metadata-file <(curl -s -L That made me realize
I did not put file type in the url (.json).
I can see accurate data in poolmeta.json file. Getting a hash when I ran below command.

cardano-cli stake-pool metadata-hash --pool-metadata-file <(cat poolmeta.json)

I want to modify this information in my pool. But when I try to modify using CNTools.
I am getting below error.
Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraMary (ApplyTxError [LedgerFailure (UtxowFailure (UtxoFailure (ValueNotConservedUTxO (Value 2197821299 (fromList )) (Value 2697821299 (fromList )))))])

ERROR: failure during pool modify!

Thanks much for your help.

Err 404

Hi Alex,
Was not sure what data I should post or not, so I just gave an example of the error.
here is the actual link.

I want to modify the pool by providing the above corrected link.
Thanks for your help.

1 Like

How did u tried to modify the pool?
It was registered already ? Did u paid 500 ADA for registration ? If yes then u must go to
Cntools - pool - modify

I used CNTools for registering/modifying my pool. I have not received the success screen on pool registration. I kept getting timeout, waiting for next block, cancel/press any key to go home, transaction would be processed in the back ground. I was able to run the producer node by changing ENV file with pool name.
Also when I tried to register the pool again, I did notice it is not available. That made me think it’s(Plava) registered.
I did transfer 2200 ADA into my wallet. I still see the same amount. Would I see less 500 if it registered? I assumed since it’s a refundable deposit it sits in the account.
Also when I try to use Show pool in CNTools, getting an error, the error suggest increasing timeout value in cntools.config.

 >> POOL >> SHOW

Dumping ledger-state from node, can take a while on larger networks…

This is timing out with below error

 >> POOL >> SHOW

ERROR: ledger dump failed/timed out
increase timeout value in cntools.config

press any key to return to home menu
I increased it to 1000 slots. restarted the node. Now it just sitting at starting…
and ./ yield below error
Looks like cardano-node is running with socket-path as /opt/cardano/cnode/sockets/node0.socket, but the actual socket file does not exist.
This could occur if the node hasnt completed startup or if a second instance of node startup was attempted!
If this does not resolve automatically in a few minutes, you might want to restart your node and try again.

ERROR: CNTools failed to load common env file
Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub
in env file this SOCKET path is commented out.


the nodes should be fully synced first, then try to go in env and edit:

#TIMEOUT_LEDGER_STATE=300 # Timeout in seconds for querying and dumping ledger-state
increase to 500 or 600 and activate the line by deleting the # from the beginning;
then go to cntools - pool - register and insert the parameters… also the wallet will loss 500 ADA after registration.

PS: I think u should create the pools first… cntools - pool - new - and after that go to register


Hi Alex,
I did increase the TIMEOUT_LEDGER_STATE=1000. I restarted my Relay nodes, my Producer node. I already changed ENV file in Producer node with pool name.
They all started fine and synced. I do see my prod node display core-mainenet with both relay node IP’s.
Next step I did is to check my wallet balance. …WALLET>>SHOW. It shows 2200 and it did not deduct 500. That kind of surprised me cause, when I go into cntools POOL>>NEW it wont let me choose PLAVA. Shows Name is already taken. Then I go into POOL>>LIST It shows PLAVA ID(hex), ID(bech32) values. Registred: Yes - check ‘Pool >>Show’ for ledger status. KES expiration date: 2021-07-15 10:12:30 UTC.
That clearly indicates it is registered right?
When I do go into >>POOL>>SHOW I get

 >> POOL >> SHOW

Dumping ledger-state from node, can take a while on larger networks…

But it doesn’t go through. It errors out with.
ERROR: ledger dump failed/timed out
increase timeout value in cntools.config. I am not sure what timeout value is right, I set it as 6000 from 600 slots.:slight_smile:
Every time this fails, I have to restart my producer node. It takes few seconds and syncs back fine.
Too many contradictions.

Yes, it should be fine, don’t worry about that… now can u give me the pool id?


Can u past the text here?

ID (hex) : ff3c2a7fed6001b90030dffa566ae93af818bfe235e7b6283ce765a1
ID (bech32) : pool1lu7z5lldvqqmjqpsmla9v6hf8tup30lzxhnmv2puuaj6ztxrkda
Registered : YES - check ‘Pool >> Show’ for ledger registration status
KES expiration date : 2021-07-15 11:24:55 UTC

Something is not ok, I can’t find the pool on or

Yeah. I was thinking may be server configuration is not good enough, so I upgraded all three node servers to 8GB ram with 80 gb disk space. But I think its not the problem.
Would it matter that the metadata json url doen’s actually have file extension? Logic tells me it should not as I was submitting the link, it was able to read the contents and echo back on the screen.
It shows registered, but 500 ADA is not gone out of my wallet YET. If it is registered, then it should let me modify it, but that is not happening. Overall it is a mess :-). Good learning experience indeed in the past two weeks are so…
I dont want to start a new pool and find out suddenly both get charged with 500. Really appreciate your time and helping me with this. You have been a great help to Cardano community from all the readings I been doing. I cant thank enough for your detailed setup instructions. Thanks again.

No change in status. Every node including Producer node shows with a green smiley but >>POOL>>SHOW keep running into the same error. Pretty much tried every solution I seen about CNTools. Now I am thinking about installing CNCLI and try that one.

Ok, checked again an the pool is not registered, can u go cntools- pool - deregister and then register again? Something is not working… if u didn’t paid 500 ADA meaning ur pool was not registered on the network

It seems that way. It doesn’t make sense why it will show >>POOL>>LIST as registered. I will try that.

Is >>POOL>>RETIRE is same as Pool - deregister? I dont see a deregister option.

But if u go to - register?
Do u have all the files… cold keys on the server?
Without these files u will see a warning

Yes. I do see all the keys. In fact, in all respects this shows as registered.

Yes, understand… but I can’t see it on any site
Can u show me what files do u have in pool folder?
Weird… u said u didn’t pay 500 ADA yet…