Port 6000 connection refused

Finding the Cardano Relay will no longer sync and it is not able to connect to the producer node on port 6000, what I did was a telnet port test on internal network there is no connection allowed.

The UFW rules are

6000/tcp ALLOW Anywhere

What am I missing?

then the port is closed … u must open the port on producer to allow the relay connection


Alex I commented out a line in scripts folder a file called ENV the line about port 6000
Does that determine the port no for the producer node I wondered why nothing is listening on this port ?

is the port opened on FW?

probably missing the Destination NAT (Port-Forwarding) on your Internetgateway(Router/Firewall/…) to your inside adress:port.

regards, obi

Hi Obi

Thanks also I am not sure the node was running correctly on port 6000 I also need to check there is a node to node firewall rule on the router too

ok - did you work it out?

Hi @obi1337

So I am still running relay tests for stability looks like its falling over and could be first to do with memory so I upped that to 16 GB. Then its also got some errors in the log. Maybe I need to make a new topic what do you think of these looks like something that needs commenting out in the env scripts ?

ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 3253073 ) is not listening on this port. Please update the config or kill the conflicting process first.

Failed to load common env file

Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

yes looks like you enabled EKG (for logging) for this port by no service is listening (Prometheus) on the server.

i think its in the config.json or if you use CNTools somewhere in the env (haven’t used CNTools so far)