ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node is not listening on this port. Please update the config or kill the conflicting process first

Hi all,

looking to retire the pool as we just weren’t able to attract delegation. However, I’m having trouble getting the BP to connect and therefore am shut out of cntools.
I am able to connect to my relay using telnet

journalctl -e -f -u cnode

yields the following:
ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node is not listening on this port. Please update the config or kill the conflicting process first.

Any suggestions on how to overcome?

try for any other errors with

sudo systemctl status cnode

Apologies, the email to say I had a message on here went to junk so I’ve not checked in.
Thank you for replying.

I get the following using your suggestion:
ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node is not listening on this port. Please update the config or kill the conflicting process first.

Nothing more

It’s using 15Gb of my 16Gb memory. Sounds a bit high to me?

and still > 100% cpu

type free -m and check if you have SWAP file configured

              total         used      free         shared   buff/cache   available
Mem:          16008         198       14382           0        1428       15537
Swap:          2047          32        2015

looks fine, now type journalctl -e -f -u cnode
what is the output, can u share the all output (since last cnode restart)?
also can u share the output for gliveview?

Jun 21 11:28:13 : /opt/cardano/cnode/scripts/cnode.sh: line 142: 2786066 Killed “${CNODEBIN}” “${CPU_RUNTIME[@]}” run --topology “${TOPOLOGY}” --config “${CONFIG}” --database-path “${DB_DIR}” --socket-path “${CARDANO_NODE_SOCKET_PATH}” --shelley-kes-key “${POOL_DIR}/${POOL_HOTKEY_SK_FILENAME}” --shelley-vrf-key “${POOL_DIR}/${POOL_VRF_SK_FILENAME}” --shelley-operational-certificate “${POOL_DIR}/${POOL_OPCERT_FILENAME}” --port ${CNODE_PORT} ${MEMPOOL_OVERRIDE} “${host_addr[@]}”
Jun 21 11:28:18 ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 2900924 ) is not listening on this port. Please update the config or kill the conflicting process first.
Jun 21 11:28:18 : WARN: A prior running Cardano node was not cleanly shutdown, socket file still exists. Cleaning up.
Jun 21 11:28:20: Listening

Screenshot 2022-06-21 at 11.04.00

Also had this error in the journal earlier:

Jun 21 08:44:25 : ERROR: Failed to load common env file

Jun 21 08:44:25 : Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

I have checked the env file and it looks correct

aply these steps, but follow the steps carefully

  1. cd db folder
  2. ls -l (here u should see more files and 3 folders)
  3. sudo systemctl stop cnode
  4. mv ledger ledger_bkp
    mv immutable immutable_bkp
    mv volatile volatile_bkp
  5. ls - l
  6. sudo systemctl start cnode
  7. after 10 -15 seconds type sudo systemctl stop cnode
  8. ls -l (now u should have the bkp files and also the new files)
  9. delete the new files (not the bkp-ed ones)
    rm -R ledger
    rm -R immutable
    rm -R volatile
  10. ls -l (now u should have the old files only)
  11. rename back the old files
    mv ledger_bkp ledger
    mv immutable_bkp immutable
    mv volatile_bkp volatile
  12. ls -l
  13. start the node and check glive
    sudo systemctl start cnode

OK looking positive, no errors on the journal.

what did the above manage to reset?

The BP still doesn’t see my relay though
Screenshot 2022-06-21 at 12.04.34

ah failed after 13 mins

Jun 21 13:01:04 : Listening on
Jun 21 13:14:53 : /opt/cardano/cnode/scripts/cnode.sh: line 142: 3028974 Killed “${CNODEBIN}” “${CPU_RUNTIME[@]}” run --topology “${TOPOLOGY}” --config “${CONFIG}” --database-path “${DB_DIR}” --socket-path “${CARDANO_NODE_SOCKET_PATH}” --shelley-kes-key “${POOL_DIR}/${POOL_HOTKEY_SK_FILENAME}” --shelley-vrf-key “${POOL_DIR}/${POOL_VRF_SK_FILENAME}” --shelley-operational-certificate “${POOL_DIR}/${POOL_OPCERT_FILENAME}” --port ${CNODE_PORT} ${MEMPOOL_OVERRIDE} “${host_addr[@]}”
Jun 21 13:14:59 : ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 3067236 ) is not listening on this port. Please update the config or kill the conflicting process first.

try sudo systemctl status | in cncli

like this?

/opt/cardano/cnode/scripts$ sudo systemctl status cncli
Unit cncli.service could not be found.

sorry :slight_smile: to much cisco :slight_smile:
sudo systemctl status | grep cncli

1 Like

:/opt/cardano/cnode/scripts$ sudo systemctl status | grep cncli
│ │ ├─3085586 grep --color=auto cncli
├─cnode-cncli-leaderlog.service
│ ├─3066982 bash /opt/cardano/cnode/scripts/cncli.sh leaderlog
├─cnode-cncli-validate.service
│ ├─3068193 bash /opt/cardano/cnode/scripts/cncli.sh validate
├─cnode-cncli-ptsendslots.service
│ ├─3066999 bash /opt/cardano/cnode/scripts/cncli.sh ptsendslots
├─cnode-cncli-ptsendtip.service
│ ├─3066980 bash /opt/cardano/cnode/scripts/cncli.sh ptsendtip
├─cnode-cncli-sync.service
│ ├─3066981 bash /opt/cardano/cnode/scripts/cncli.sh sync

perfect, now disable the services, and restart the server (sudo reboot)

sudo systemctl stop cnode-cncli-leaderlog.service
sudo systemctl disable cnode-cncli-leaderlog.service
sudo systemctl stop cnode-cncli-validate.service
sudo systemctl disable cnode-cncli-validate.service
sudo systemctl stop cnode-cncli-ptsendslots.service
sudo systemctl disable cnode-cncli-ptsendslots.service
sudo systemctl stop cnode-cncli-sync.service
sudo systemctl disable cnode-cncli-sync.service

PS: cncli leaderlog will use additional ~11G of RAM to calculate next blocks assigned, that’s why the server crash due to insufficient RAM

~$ sudo systemctl status cnode
● cnode.service - Cardano Node
Loaded: loaded (/etc/systemd/system/cnode.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2022-06-21 13:35:35 CEST; 3min 2s ago
Main PID: 633 (bash)
Tasks: 10 (limit: 19141)
Memory: 4.1G
CGroup: /system.slice/cnode.service
├─633 bash /opt/cardano/cnode/scripts/cnode.sh
└─859 /home/producer/.cabal/bin/cardano-node run --topology /opt/cardano/cnode/files/topology.json --config />

Jun 21 13:35:35 : Started Cardano Node.
Jun 21 13:35:35 : ERROR: You specified 12788 as your EKG port, but it looks like the>
Jun 21 13:35:37 : Listening on http://127.0.0.1:12798

share glive again