ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 1454 ) is not listening on this port

I am getting this error on my relay machine after updating gLiveView. I am on version 1.35.6. The cardano-node seems to be running fine and my bp node is connected to it. I have tried restarting the server several times.


Have a look here.

I haven’t seen many running 1.35.6, mostly 1.35.5, 1.35.7 or 8.0.0. You could try rebuild to 1.35.7 or even 8.0.0. I suspect your issue is your db, hence the suggestion in the linked topic.

check for errors with journalctl -e -f -u cnode
I don’t see listening on… message

must be an error there

I’ve upgraded to 8.0.0, added the ConwayGenesisFile, modified the config with ConwayGenesisFile and Hash but am still getting the same error. The odd thing is is that the error says cardano-node running on PID: 8170 but that process is not on the list:

It seems to be a change in the config i did to disable logging which I thought was benign. I was running out of space on the server and decided to disable logging as the log files were getting 10G+. I modified this line in the config:

“TurnOnLogging”: true,

and changed it to

“TurnOnLogging”: false,

And all the problems started there. Do you know how to turn logging off so that I can save space on the server?