gLiveView failed to load common env File and ERROR: Wrong EKG Port

Beginner Stake Pool operator here, just been creating my first build on the test net with a single machine acting as a relay. Everything seems to be working fine, I got the node to be active and was able to follow the log with journalctl --unit=cardano-node --follow

But when setting up gLiveView i got the error

ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 2931 ) is not listening on this port. Please update the config or kill the conflicting process first.

ERROR: gLiveView failed to load common env file
Please verify set values in ‘User Variables’ section in env file or log an issue on GitHub

See above Screenshot

I tried changing the port in the config env file but still recieved the same error with the same port message, im a little confused on where I need to be looking and what exactly i need to change for a testnet setup of gLiveView.

How I got here:

sudo apt install bc tcptraceroute -y
curl -s -o
curl -s -o env
chmod 755


sed -i env \
    -e "s/\#CONFIG=\"\${CNODE_HOME}\/files\/config.json\"/CONFIG=\"\${NODE_HOME}\/testnet-config.json\"/g" \
    -e "s/\#SOCKET=\"\${CNODE_HOME}\/sockets\/node0.socket\"/SOCKET=\"\${NODE_HOME}\/db\/socket\"/g"

Then ran gLiveView with ./

sorry if this has already been answered somewhere in the forums, I couldn’t find anyone with this specific issue.


Restart the server

I’ve tried restarting the server a few times now and also tried changing the EKG port before a restart, the PID changes which I’m guessing is a cardano-node its trying to communicate with but it still says im on EKG port 12788 which I know I have changed. Is there a specific EKG port I should be on for testnet?

nope, the ekg port is specified in config file and it can be changed

“hasEKG”: 12788,

Well ive tried multiple ports and port 12788 by changing the following config file:

Am I supposed to uncomment all of the user variables or just the ones I wish to change? I mean it does say leave if unsure so.

Comment the ekg line only

you mean uncomment right?

Okay so I tried uncommenting everything leaving the EKG port commented, then it complained about the Prometheus port not being correct on 12798. Tried commenting that one out too but it still complained about the prometheus port. Really sorry mate if this is simple stuff, i’m a python programmer i’m not so educated on linux administration.

commit everything except

log dir
db dir

and paste the script which u are using to start the node

Okay so I committed everything except cnode, config, socket, topology, log dir, db dir as seen in screenshot

Then i used sudo systemctl reload-or-restart cardano-node to restart the node

To which I get the following:

I also tried the exact opposite and commented the things you said and left the others uncommented incase you miss spelt comment haha. but that just gave the EKG port error again.

I had a look for a checkupdate function but only found a boolean which was already set to Yes.

Yes, try to switch to N the line (update check)

changed UPDATE_CHECK to “N” tried both commenting it and un commenting it but both times I now get the same EKG port error.

Ok, type top

how many cardano-node process do u see?

also try sudo systemctl status cardano-node

and journalctl -e -f -u cardano-node

type top?

yea my status is active, and does journalctl -e -f -u cardano-node just print out the whole log because thats what I got.

I reviewed and inside inv u must have uncomment only 3 lines:


show me the script


Cnode port

show me the script

I remember making the script in my NODE_HOME dir but its not their or hidden, is it stored in a diferent dir?

lol im dumb found it

So update for anyone else thats reading, still not solved.

Here is the script

Tommorrow I will just completely remake the node on testnet and try again but this time with a relay and a producer build.