gLiveView failed to load common env File and ERROR: Wrong EKG Port

I have come to an interesting finding, I have managed to run the gLiveView by running it while the node is not running. Then turning the node back on after gliveview is already running. However I do not see any peers which makes me think either the blockchain hasn’t synced yet or that gLiveView still thinks the node is off. Any insight would be much appreciated.

That’s because u probably run more than 1 node on the server

try sudo systemctl status cnode
sudo systemctl status cardano-node

Heres what the statuses returned

So just to recap on how I got everything working. For some reason gLiveVeiw only works for me if I start it before the node. And then to get the peers working i found after reading another thread you just need to turn TraceBlockFetchDecisions to True and now I can see my outbound peers.

I’m also seeing this same exact error with this goofy shell script.

So does this mean we can only use gLiveView.sh if it’s running before we start the node service?

What if I stop gLiveView and start it up three days later?
Does that mean I also need to restart my cardano-node service?

If this is indeed the case then that simlpy makes gLiveView.sh an impractical tool.
Or what really is the issue?

I found that after rebuilding my node gLiveView worked perfectly.

Do you suspect or have an idea as to what you previously had misconfigured?

No I don’t sorry man, I tend to fix problems by just flipping my desk and starting again lol.

1 Like

Ok, so you reinstalled your OS?

Is that what you mean by “flipping my desk”?
Or you let computers make you an angry person…lol…j/k

Switch to cntools :wink:

1 Like

This here?
lol…more shell scripts.

Check my topic… how to… but u will need a fresh OS install

And DO NOT RUN the command from STEP 2 (skip it)


git pull origin master

Had this issue with one relay updating from 1.29.0 to 1.30.1. The solution was to recompile cardano-node and cardano-cli.

The node worked, but gLiveView would not start with this same error.

Some compilation/disk error must have occurred the first time.

did u edited the env file? In case u downloaded again

also try journalctl -e -f -u cardano-node

Hi, I didnt edit anything.

Just recompiling the binaries solved it.

Just now I’m having this issue too on my BP. Everything was working fine but now I can’t initiate gLiveView or CNTools.

Node is active but very low memory usage.

● cnode.service - Cardano Node
     Loaded: loaded (/etc/systemd/system/cnode.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-10-12 22:54:25 CEST; 1min 4s ago
   Main PID: 3504018 (bash)
      Tasks: 10 (limit: 19146)
     Memory: 89.1M
     CGroup: /system.slice/cnode.service
             ├─3504018 bash /opt/cardano/cnode/scripts/cnode.sh
             └─3504299 cardano-node run --topology  --config /opt/cardano/cnode/files/config.json --database-path  --socket-path /opt/cardano/cnode/sockets/node0.socket --port XXXX --host-addr 0.0.0.0

Oct 12 22:54:25 vmi618303.contaboserver.net systemd[1]: Started Cardano Node.
Oct 12 22:54:25 vmi618303.contaboserver.net cnode[3504018]: ERROR: You specified 12788 as your EKG port, but it looks like the cardano-node (PID: 3504259 ) is not listening on this port. Please update the config or kill the conflicting process first.
Oct 12 22:54:25 vmi618303.contaboserver.net cnode[3504286]: mkdir: cannot create directory ‘/archive’: Permission denied
Oct 12 22:54:27 vmi618303.contaboserver.net cnode[3504299]: Listening on http://127.0.0.1:12798

When I initiate gLiveView I onlt get this message:

COULD NOT CONNECT TO A RUNNING INSTANCE, 6 FAILED ATTEMPTS IN A ROW!

When I try to run CNTools I get this error message:

CNTools version check...

WARN: failed to query protocol parameters, ensure your node is running with correct genesis (the node needs to be in sync to 1 epoch after the hardfork)

Error message:

INFO: re-run CNTools in offline mode with -o parameter if you want to access CNTools with limited functionality

**crdnjs@vmi618303** : **/opt/cardano/cnode/scripts** $

Restarted the node. Stopped and started the node. Looked at all the user variables but I didn’t make any changes.

Will try to recompile when I get back home.

I just updated and rebooted the server and this solved it.

1 Like