Problem with node startup (code=exited, status=126)

Hi, I have an issue when starting the Node, and I haven’t been able to find out what the problem is. I’ve reinstalled the server, created the node from scratch, but I keep getting the same error. Here are some images.


Has the script executable permissions?


Hi Alex, thank you for your response. The permissions I have granted are the following:

chmod +x $NODE_HOME/


sudo chmod 644 /etc/systemd/system/cardano-node.service



1 Like

Try to start the node manually not as systemd… are u receiving same error?


The error message I’m getting is: -bash: ./ /bin/bash^M: bad interpreter: No such file or directory.

When I run this command: journalctl --unit=cardano-node --follow, I receive the following error:

Jan 06 16:45:29 cardanopro cardano-node[39597]: /bin/bash: /home/cardano/cardano-my-node/ /bin/bash^M: bad interpreter: No such file or directory

It looks like u have some characters unrecognized by linux… recreate the script directly in linux using nano or vi


Alex, which command should I execute to recreate the script directly?

Is this what you mean?

Alex, thank you very much. I’ve already solved the issue. It was more complicated than I imagined. I converted the script using:
dos2unix /home/cardano/cardano-my-node/

Afterward, I gave the specified permissions to the script:
chmod +x /home/cardano/cardano-my-node/

I also converted the file:
dos2unix /home/cardano/cardano-my-node/cardano-node.service

and moved it, respectively to:

sudo mv /home/cardano/cardano-my-node/cardano-node.service /etc/systemd/system/cardano-node.service
sudo chmod 644 /etc/systemd/system/cardano-node.service

The next step is that I’m not sure why I hadn’t copied the files:
sudo cp /home/cardano/.local/bin/cardano-cli /usr/local/bin/
sudo cp /home/cardano/.local/bin/cardano-node /usr/local/bin/