Problems into Relays and BP from yesterday

I just updated my system days ago and it was working all well untill yesterday.
Now the node’s status is starting and showing epoch 0. There are no peers IN or OUT connected to the relays.
I didn´t make any change after upgrading to 1.29
Any idea what it can be happening?

Many thanks in advance.


1 Like

how are the relays, are synced?

They have the same status, starting….

journalctl -e -f -u cardano-node

too many errors shown with that command.
for example
Sep 13 20:47:42 serv3 bash[363343]: [serv3:cardano.node.IpSubscription:Error:416334] [2021-09-13 20:47:42.21 UTC] IPs: [,,,,,,,,,,] Application Exception: InvalidBlock (At (Block {blockPointSlot = SlotNo 39878638, blockPointHash = fbfe615bdeed74f73463a17bf44037e8831cc4072e22c4e10366da3e54f7})) (ValidationError (ExtValidationErrorLedger (HardForkLedgerErrorFromEra S (S (S (Z (WrapLedgerErr {unwrapLedgerErr = BBodyError (BlockTransitionError [LedgersFailure (LedgerFailure (UtxowFailure (MissingVKeyWitnessesUTXOW (WitHashes (fromList [KeyHash “bf8a5bb8da7dbe4c272056d67aeda1a87c750931737b4063d2”])))))])})))))))

Too many similar like this

All nodes are down?

Yes, all of them with the same result.

Try for one node to apply this WA

Delete the db and download the db from here

any guide somewhere to follow without errors, please?

Do a simple update as you would normally in the pass. coincashew and cntools guides work. also there are a few on the form that will work as well.

Ok I will try to run a refresh of the db and will tell you back.
Many thanks

Hello again,
Many thanks for your help before. I updated db in my nodes and now my BP is working well and one of the relays is working well too, but the second relay is still showing status “starting” after it has downloaded a full db.
all versions are correct, but don´t know what it can be happening.

Any idea what to check?

Many thanks

journalctl -e -f -u cardano-node

I see now this error using your command.

Sep 21 07:16:43 relay3 bash[1543186]: Shutting down…
Sep 21 07:16:43 relay3 bash[1543186]: cardano-node: decodeTelescope: invalid telescope length
Sep 21 07:16:43 relay3 bash[1543186]: CallStack (from HasCallStack):
Sep 21 07:16:43 relay3 bash[1543186]: error, called at src/Ouroboros/Consensus/HardFork/Combinator/Serialisation/Common.hs:443:27 in ouroboros-consensus-
Sep 21 07:16:43 relay3 systemd[1]: cardano-node.service: Main process exited, code=exited, status=1/FAILURE
Sep 21 07:16:43 relay3 systemd[1]: cardano-node.service: Failed with result ‘exit-code’.

did u downloaded the files for alonzo?

Yes all files where correctly downloaded when upgraded.
I have just copy them again but getting the same result…

Now it seems to be working with DB again… will wait to see…

1 Like

Hi Alex. Finaly the node started but sometimes it get disconected. What do you think about this error?

It looks like u don’t have enough RAM
What is the server hardware configuration?